Built-in keyboard and touchpad not working (USB ones do)


I reinstalled PureOS from install (not Calamares) and both the keyboard and touchpad stopped working.

I chose install from the USB drive and not live because of this issue. When I installed, I had my USB keyboard and mouse connected, which may have created the problem in the first place, but fresh installations don’t fix the issue. I tried both install and live with the same result.

When I’m prompted to put the disc encryption password I’m able to type one character, then the keyboard stops working and I need to use the USB.

Any ideas how to fix this?


Friendly ping @mladen :smiley:

Did you end up figuring it out? As a potential customer, hoping that customer reported issues can get fixed…

Short answer: yes.

I continued the conversation by email, that’s why this thread is just hanging here. We couldn’t figure out the problem, but they were very helpful and replied quickly.

In the end the solution was to send the computer back to them for service. They still have it, so not solved yet, but I’m confident it will be.

In general I’m very pleased with the product itself and the support. So they have my :+1: