BYD touchpad now seems to have stopped working altogether

Sorry, me again. I was having reasonable success with the touchpad until this morning. I realised that with Elementary OS (built on Ubuntu 14.04) and kernel 4.1.20, bluetooth didn’t seem to be working (in system settings all options were greyed out under Bluetooth). So I tried updating the kernel to see if that fixed it (I had used Timeshift to create a snapshot of where I was before). Sadly, no version of the kernel seemed to get bluetooth working, even rolling back to 3.19 which is what Elementary comes with.

In the process, the touchpad stopped working. I have tried reinstalling the drivers and rolling back with Timeshift. It’s just totally unresponsive. So now no bluetooth and no touchpad. :frowning: I’m using an old wired mouse at the moment. Any ideas of what I can try? I’ve scoured the Ubuntu/Elementary forums and tried various fixes with no luck so far.

I’ve posted about this on the Elementary StackExchange with some additional details:

So, I’ve ended up formatting and reinstalling PureOS in an effort to get the touchpad and bluetooth working. Alas, this still hasn’t got things working.

So now I really am at a loss. It’s feeling like this might now be a hardware issue. :frowning:

Hi Jack,

I have more experimenting to do before I post what I’ve learned in one of the PureOS threads,
but you might find this bit immediately useful.

Recall that FN-F1 (Hold function key down, tap F1) toggles the touchpad active state. Toggle
it off and the pad does nothing; toggle it on and the pad works again.

The important thing to realize is this setting is sticky regardless of anything the OS tries
to do about it, and it persists across reboots even if you cycle the power. I have no idea
where the state is stored. It almost has to be in the pad hardware itself.

So it may be if your pad is dead all you need to do is FN-F1 and you’re good to go, however…

…under some circumstances the off setting can get stuck, and the key chord can no longer
enable the mouse. There are probably other ways to get into trouble, but what worked
consistently for me was:

  1. Boot into PureOS 2.0
  2. Verify on the desktop or at the login screen that the pad moves the mouse cursor,
    then use FN-F1 to toggle it off. Verify it’s dead.
  3. Hold the power key down briefly to get the system to do an orderly shutdown and
  4. Reboot into PureOS. At this point you will find the pad still off, and it can
    not be toggled on again.

They way I found to unstick it was to boot into a Fedora kernel which did not have
the BYD driver. Once at the login screen FN-F1 would activate the pad again, and
upon subsequent reboot into PureOS it continues working. It’s worth mentioning that
if the pad is working when PureOS shuts down, it will still be working next boot.

So if you boot an older kernel without the BYD driver and FN-F1, that may fix you up.

No doubt whoever manufactures the pad hardware would call this a feature.

Hope that helps.

Hello Dennis, well what can I see other than OH MY GOD THIS FIXED IT.

I must say, I don’t know whether to laugh or cry. The amount of time I have wasted trying to fix this (even formatting the machine, losing some of the config I had been sorting out), and all I had to do was press FN-F1…

Anyway, despite my frustration at the simplicity of this problem, I am incredibly grateful. Thank you so much for sharing this with me. I can finally use this thing again!

1 Like

Thanks Dennis, I’m very glad to have come across this tip even though I haven’t accidentally triggered the same problem yet.

1 Like