Byzantinum updates ruined my installation

I have been running sucessfully the KDE/Plasma blend of Byzantium. The latest pdates ruined my installation.
My Purim 13.3 stops working, when it tries to connect to the Wlan. Sometimes kwallet is interfering too. I have not set a password but it wants one.

I tried selectiv updates via synaptic, so I do not update the Networkmanager and will try this morning what happens if I purge Kwallet.

Do you have any ideas or hints. The iso of Byzantium is from 20.11.20.

You have to be more clear about what happen with your system because a prompt asking for a password isn’t a ruined one, write down step by step whats going on when you start the computer.

PureOS Byzantium it’s likely to do this kind of stuff if you are new to the GNU/Linux ecosystem you should stick to Amber.

try the latest image of PureOS-10-Byzantium with GNOME as desktop-environment (DE) and see if you have the same problem >

what hardware do you have ? motherboard, CPU/GPU and network-interface-card are most important … maybe keyboard too (i had some problems with mine but it got resolved pretty quickly from the manufacturer). monitors should be OK if you don’t have some crazy scaling requirements …

1 Like

Thank you. I have the the Purism librem 13.3, which worked fine until recently. I will test the Gnome Flavor and see, what happens.


I have installed byzantium gnome oem, updated it and installed firefox, tor, dolphin and okular. Everything works fine, so my 13.3 hardware seems to be okay.

I will install byzantium KDE/Plasma on the second SSD in my Purism 13.3 and see what happens.

I use gnu/linux for at least 20 years, so bysantium seems to be o.k. for me.

After the installation my Purism 13.3 starts until he tries to conncet to the wlan, than a box opens, not the prompt in the konsole, and wants a password for kde-wallet. As I have not set one, I cancel and then it wants the passphrase for the wlan connection. When I enter it, the computer freezes.

When I connect to the wlan at the beginning oft the installation, it connects to the wlan without problems, I can install KDE/Plasma, but I am not able to restart successfully.

1 Like

I’m not a KDE user really but you could try this

1 Like

Just FYI I have been running Byzantium on Librem-Mini for a few months already with no issues.

Unfortunately this did not really help.

When you removed the password after restart it asked again for the password?

PS: Write down every step you do in here if it’s possible

1 Like

Yes after reboot, it asked again for a password.
There is only on step. I boot, login and the kwallet wants a password. I try o.k. without entering a password, as i did not set one, again it wants a password. I leave the box with esc, the I have to enter the password for my wlan. I enter it and the the startup sequenze freezes.

I tried something new. I installed Byzabtium/KDE/Plasma. After the installation I activate Kwallet and set a password, which I had to enter, when I entered the password for my wlan. Then I rebooted and it works fine, I could enter the Kwallet Password. Then I installed synaptic and updated the system after that, the same behavior. I enter the kwallet password which is not accepted. After entering the wlan password, the system freezes.

I tried something different: I installed Byzantium/KDE/Plasma from the ground on. I started the fresh installation and installed synaptic sudo apt update. I disabled Kwallet. With synaptic, i updated the packages in parts of 40 - 50, not touching anything of Kwallet, networkmanager and modemmanager. After the installation I shut down and started new. In this way I could update about 500 of the 670 packages. After updating the next 20 packages, the system hangs when booting. Kwallet is still disabled.

I will now try to find out, which package is responsible for the hanging of the system.
I will now try to find out, which

i have had these “freeze” problems on a different machine but not with PureOS and NOT with Purism hardware.

could be some driver/firmware quirk that’s lurking somewhere or it’s an Ai invasion :sweat_smile:

I have installed KDE Neon on my second SSD in my purism 13.3. It works without problems. I can update and install packages.

So the reason of my problems must lie in the updates of byzantium. A working version of byzantium must be possible.