Calibre no longer supported

So I go to the PureOS software store, and try to install Calibre and it say, “Not supported”. Has this changed and Calibre needs to be removed from the store?

Update, it says not supported, failed to install, but, it actually seems to have installed.


What version of PureOS are you using Byzantium or Amber?

I check for and update the latest OS on my L14 daily through the software app. All the L14’s have Byzantium right?

I reported the error and left it here partially has an FYI for Purism developers even though the install seemed to have worked.

I have calibre v 5.12 working on my L14.

It’s working on mine too, just wanted to mention the “not supported download failed” error message I got anyway.

I have v5.12 installed from debian-stable-main on my Pinephone-Mobian-phosh. Debian rarely updates Calibre, but the version from Goyal’s website updates regularly on my Mint workstation.

I donated to Goyal and encouraged him incorporate libhandy, but he wasn’t even remotely interested, even when I told him that the included eBook Reader was already 99% working on Mobian and that it was the best reader on phosh. He rather rudely asserted that his reader was only intended for desktop use… Sheesh!

1 Like

I would love to see calibre on a small device!

1 Like

I just tried it on the L5 (from the amber repo). The interface, although jerky and laggy, almost looks like it could work with a little dev work, but it’s probably a bit frustrating to use.

In the meantime, there’s Foliate, which you can see in this sampling of apps: List of Apps that fit and function well [Post them here.]