Cannot boot my librem 13 v3 after OS update

Hello, this morning I did an apt update followed by apt upgrade. All went well until after rebooting. My librem got stuck. Here is how it goes:

  • Press the power key
  • Purism logo appears on screen
  • console screen: attempting to decrypt master key... Enter passphrase for hd0,msdos2 (6a65-...):
  • whatever I type here has exactly the same effect later, be it my LUKS password, random text or even just pressing ESC
  • GRUB appears -> PureOS GNU Linux
  • Graphical mode: please unlock disk luks-6a65... I type my LUKS password
  • cryptsetup: luks-6a65... : set up successfully + the PureOS Logo, this time in text.
  • it hangs there.
  • I hit ESC, that switches to console mode: there is something looking like a boot sequence:
  • i915 0000:00:02.0: firmware: failed to load i915/skl_dmc_ver1_27.
  • firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
  • Volume group “luks” not found
  • Cannot process volume group luks
  • Volume group “luks” not found
  • Cannot process volume group luks
  • /dev/mapper/luks-6a65…: recovering journal
  • /dev/mapper/luks-6a65…: clean, 539136/29327360 files, 25813988/117306274 blocks
    -[*** ] A start job is running for /dev/mapper/luks-2d34… (5min 13s / no limit)

and it stays like that.

Note that the start job is for a different uuid than the other luks related messages.

I can still boot in recovery mode though, that is how I am typing this message.

I am wondering what went wrong. And what am I missing in recovery mode.

Any help would be appreciated.

Hi @bastien, I’ll try and help you with this issue. Firstly, thanks for the detailed report, this is immensely helpful. But I think there are two things at work here, one is luks the other is firmware. I say that because I too have an issue with the firmware but I’m able to boot normally. What happens on my end is that it loads an older version of the firmware later on in the boot process. I wonder if that is the case with you as well? If so, then we can rule out firmware being the culprit here possibly. May I ask that you do this command and paste some output;

journalctl -b

That command will dump the system log from the last boot. You should see similar output to what I have had and put in our issue tracker here: https://tracker.pureos.net/T718

Meanwhile I’ll look into how to update the firmware or if this is necessary.

Thanks @jeremiah

Regarding the missing firmware, I have a very un-scientific approach here: I am pretty sure I have been seeing this message for a while now and even thought I should be looking into it.
On top of that, journalctl -b shows exactly the same output as yours ending up with an initialized i915 1.6.0.

So I think we can rule this out.

The luks thing though looks quite new, I can’t remember having seen this before, nor does my browser history.

I thought I would ask here mostly because I have a stock PureOS on top of the Librem and thought that if it happens to me it should be happening to more people. But maybe it’s only me.

1 Like

It’s not only you. :slight_smile: In fact I have had this issue as well with the luks encryption key. In my experience however, it matters greatly what you put in to the terminal. I was putting in my password, it was the right password, but it was being input incorrectly because, unbeknownst to me, my external keyboard had numlock on. I switched to my laptops keyboard, but setting numlock on the external keyboard still had an effect on my laptop keyboard so I had to use the NumLk to turn that off and then use the laptop keyboard to enter the correct password to boot.

Are you using an external keyboard?

For about a week now, I get the 7 first bullet points of OP on my L13 v2 with stock Pure OS Then it goes on to boot normally.

Can you both check to see if there is a "GRUB_ENABLE_CRYPTODISK=y" line in/etc/default/grub ?

If so, you can comment that out, then do a ‘sudo update-grub’, and then reboot. Grub should stop asking for a password then.

I don’t use an external keyboard. Actually I don’t have anything plugged into my Librem at the moment.

I have commented the line in grub config and sure enough it stops asking for the password. But the behavior is still the same.

As soon as I get some time I’ll look into the luks volume group not found error.

1 Like

Perfect! Thank you for your help.

1 Like

it’s getting trickier to boot. I try to avoid rebooting, but at some point I’ll have to do software updates. Sometimes the system goes a bit out of control and I have to reboot. This morning I thought I would not be able to boot any more as the recovery mode was not working. I succeeded but I don’t know how I did it.
My Librem is my work laptop and there are some moments when I can’t really afford to be fiddling with boot menus. I knew what I was getting into when I bought it though, so no problem with that.
I think I’ll try to find a moment to backup and re-install the OS. I’ll let you know if it helps.

Hi bastien, sorry to hear about the continued issues. If you reinstall the OS, perhaps you might want to use the GNOME-Live image we build for PureOS: https://downloads.puri.sm/live/gnome/2019-02-10/

This will allow you to boot from the live image if you put it on a USB or a SD Card right into a working PureOS instance. Here’s some instructions on how to do that: https://tracker.pureos.net/w/installation_guide/live_system_installation/

Any issues you encounter this forum can likely help you with, simply post here and I’ll be on the lookout.

Godspeed

Just as a general tip I find useful for any future readers:
when installing an OS, I keep a separate /home partition. That way, it’s super easy to reinstall the OS at the root partition while keeping all my personal stuff (music, files, work stuff). This eliminates the need of re-copying all that data every time you want to try a new distro or just need to reinstall the OS to fix something that went wrong. You just need to tell the installer to use your existing /home partition as the /home partition for that install.

Of course, you should also keep /home backed up somewhere!

1 Like