Cannot boot new Librem EC iso

I’ve tried to update Librem EC for my Purism Librem 14 following these instructions.

But I’m unable to boot into the .iso after burning it into a USB drive:

I burned the .iso using dd as said in the instructions.

I tried also a second time with Balena Etcher, and it game me a warning saying that the .iso lacked a boot partition so it was not bootable. When I tried to boot into it anyway I got the same error as in the picture.

1 Like

It looks like your USB media is formatted as exFAT. Try reformatting it as FAT32 with the ISO. PureBoot can’t read exFAT drives yet.

1 Like

Here are more updated instructions:

If you want to skip the USB drive requirement, you can use @NineX’s instructions:


I was mistaken about exFAT being a problem unless you’re using PureBoot 28 or older:

exFAT is now supported for USB media (fixes mounting some USB flash drives)

1 Like

They point to the same GitLab repo with the same ISO image.

Can I do this from Qubes?

Should I do it from a live PureOS USB drive?

1 Like

I didn’t get this warning (tested with Balena Etcher just now) - please check your ISO and re-download if needed.

Here’s the digest of the latest ISO:

$ sha256sum Librem_14_EC_Update.iso 
d2ebbc8cb06244a363b192fb2bf4e31ac92d70aca882bd30ae32dd6cd8e08a9f  Librem_14_EC_Update.iso
1 Like

(Missed this initially as we posted at the same time.)

I recommend doing it from the EC update ISO live boot (which is offline).

EC updates complete by cutting power to the system, it can’t do a clean shutoff since the EC firmware that booted the system has now been replaced.

It probably would work from Qubes dom0 (I have not tested this), but the risk of disk corruption is greater as the ectool can’t sync filesystems for any Qubes before shutting off the system, I believe.

1 Like

I usually flash the EC firmware with this method, among other administrative tasks, but it is up to you.