Cannot connect to network

Before you start with new installation of PureOS I think that this link (Answer) is useful to be mentioned here. At least to be aware of: “It should be noted that the firmware does not conform to either Debian DFSG, nor GNU’s definition of Free Software …”.

And, I guess you’ll need to install firmware-misc-nonfree*.deb as well (might be for sure). Sidenote: I can easily understand that this Tosh laptop (old, but quality product) deserves to be used again (therefore my recommendation, as your second option, would be to try out firmware-10.5.0-amd64-DVD-1.iso), and afterwards (just perhaps, recommendation only) by replacing old HDD drive (S-ATA) to relatively small 2.5" SSD (if pleased with achieved results from the new OS installation), up to max. of 128GB (64GB is just enough space for any Linux distro and therefore recommended from my side for this particular purpose/upgrade).

That was my comment a while ago why nobody uses Linux, essentially it’s drivers or incompatibility with drivers that may be proprietary especially when it comes to laptops.

When I tried to use My Sony Vaio computer about 10 years ago Linux could not connect to WiFi so just gave up.

I believe for Linux to make inroads it needs to provide a more robust driver library or stack to allow any hardware to connect.

1 Like

That’s all very well but if the manufacturer of the device does not provide sufficient and/or accurate and/or complete info to enable an open source driver to be written - or the manufacturer only releases the information under Ts&Cs that would be unacceptable - or the manufacturer provides no information at all and only releases a closed source driver and for Windows … then it is not as easy as “Linux should provide a driver”.

That comment isn’t really directed at the “Sonys” of the world because typically they are just using components and chips - and it is usually at that level that information is lacking.

So there are two ways it could go:

  1. It’s chicken and egg. If we are lucky then enough people use Linux despite the manufacturer, and then eventually the manufacturer sees the opportunity to make more money and provides better info. (If we are unlucky then people just stop trying to run Linux on Windows-running laptops.)
  2. You forget about running Linux on your Sony Vaio and accept that Sony sold you a dud that is locked into only ever running Microsoft Windows (for better or worse) - and you buy a laptop from a company that specifically sells laptops that run Linux (like Purism or System76) or at least from a company that warrants that the laptop runs Linux (e.g. Dell).

There are of course shades of grey. Sometimes enough of the Windows-running laptop works under Linux for it to be viable but you have to put up with some components never working.


I think only question here is if the drivers are provided from free or non-free Linux repository. For those not bothered with the mentioned difference (kind of easier approach) there are even lists of officially certified hardware that will work with Linux “out-of-the-box” (even though usually bought with preinstalled Windows), one optional example is here (this one exists for years), as @kieran already suggested (it makes difference when choosing adequate hardware/manufacturer for the particular Linux distribution/usage).

Take it from this neophyte, that enough people (like me) might use Linux if, it is as easy to use as what they are use to. I had no idea what a ‘sudo’ was and it was sink or swim . Now I am learning a tad, but I don’t have the time I would like, so like the major OS, I just want it work. I’m sure it will, on any PureOS compatible hardware.

Also, if I may; at the get-go, I sense a lot of things are named something just to be different. On one O/S for example, we have “Start” another “Menu”, another “Activities”. All pointing to opening the same thing.

As clumsy, clunky, buggy, and invasive as the major O/S may be, most people I associate with don’t care - as long as they can get their work done, and is compatible with the ‘others’. My “arrrrgg!!!” falls on deaf ears. They are employees or freelancers whose time doesn’t permit a steep learning curve and don’t need to jump around incompatibility issues.

I get the sense that Purism needs a strong and aggressive marketing program. I get it. We need to buy hardware that is fully compatible with PureOS. I saw a list recently posted by @quarnero showing manufactures that Ubuntu is compatible with. That works for people who are ready to buy into a whole new way of doing things.

I think PureOS is very unique in that it works best when installed in it’s own home. Getting people buy a new home ‘finir’ PureOS will be difficult, let alone learning a new ‘desktop’.

All above is IMHO.


Just letting you know I’m not ignoring you. I just have’t had time of late to try your ideas. I will - promise :slight_smile:~s~

1 Like

sudo is formed by joining together “s”+“u”+“do”. in other words

  1. s (stands for super)
  2. u (stands for user)
  3. do (stands for do or it refers to an action - a verb)
    it’s basically saying something like this :
    “i’m the highest ranking user here and you will do EVERYTHING i tell you to after i give you my password”
    so you
    or you
    sudo (mostly)
    it’s not a big mistery. you just need to get with this autistic way of thinking :sweat_smile:

Any Linux distro will be better for the mainstream when you don’t have to know what sudo is. However in this case @sharon wrote “had no idea”, not “have no idea”.

But then you get companies trying to trademark a “look and feel” etc., which forces other companies to be a bit different, particularly those who don’t have millions of dollars to spare for multi-year lawsuits.

The link only shows what is in some 30+ packages. It’s just a non-linking list. A search for " firmware-realtek (20190114-2)" that I got from your “sudo-” line (above).

I get 7 results with weird names bedside them. The only one coming close is "buster (stable) (kernel): Binary firmware for Realtek wired/wifi/BT adapters [non-free] 20190114-2: all Would this be the one? It’s link is Buster Stable. The list with the Buster link links back to the list - getting dizzy now!

SORRY!!! Just discovered that it’s a merry-go-round.** The list link is a list. The Buster link goes to the list. More circles.

The idea of using Ubuntu first was already tried, and Mint as well. Ubuntu wi-fi worked, Mint just draws a black screen once desktop is loaded.


1 Like

Yes, Buster Stable link (dpkg -i firmware-realtek_20190114-2_all.deb) should work under PureOS umbrella, but no promise it will work out-of-the-box. Please don’t forget that apt update and apt upgrade (if needed) needs to be executed before such installation.

First, I’ll have to translate what a “iw” is and I need a few days to find out what “hostapd” needs because “There are three implementations: Jouni Malinen’s hostapd , OpenBSD’s hostapd and Devicescape’s hostapd

Could such a thing become more confusing? YES! Because each of those has a weeks worth of classes to take to understand what it is, which is the right one, how to get past the explanations, and find it, then install it. Is Linux/PureOS designed to keep out us riff-raft that were not born with a Linux manual in our heads? They don’t make it easy. Must be a reason.


I did “forget” because I wasn’t told. OK, order then is IW (still looking up that H–k that is!) then each of the " hostapd" (trial an error?) then the “Buster Stable link”?

Wish I had know about the IW and hostapd BEFORE I followed the instructions (twice) for Buster.

Maybe. I should just wipe the drive, reinstall PureOS and then do the IW (is that a i or a L (lowercase)?), hostapd and Buster in the correct order? Is there anything else I should have done pre-Buster?

It is explained within above link:
root@localhost:~# apt-get install iw (direct link) and PureOS one is here,
root@localhost:~# apt-get install hostapd (direct link), yet for this you need to change approach because of few dependencies. Perhaps under PureOS you already tried to use:
sudo apt install iw
sudo apt install hostapd EDIT: NOT to be used with PureOS!

Or usage of only dpkg -i firmware-realtek* was successful?

No, you already noted that:

and therefore clear that you need to follow very same setup under PureOS, but with non-free Debian Buster package(s).

I know you are very busy and are not expected to remember everyone and their ‘thing’, but Ubuntu as previously explained, is on another laptop and I did say, MINT is ON this ONE as dual boot option.

PureOS WiFi is still not working. And I did manage to track down what ?w is, and did that as well as hostapd and then the realtek install again and still get those errors:

cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries
nor crypto modules. If that’s on purpose, you may want to uninstall the
‘cryptsetup-initramfs’ package in order to disable the cryptsetup initramfs
integration and avoid this warning.

BUT, cable works!!!
I do not see how installing Ubuntu on here, then deleting it and re-installing Pure will leave behind the correct drivers so Pure can use them. With it being MINT, not Ubuntu on here as dual-boot, Mint booted, but then screen goes black and Mint as only on because someone suggested it. So MINT is just baggage right now.

WHAT EVER! I’m wasting your time, server space, and bandwidth and my ulcers are having babies. And because today is my day off and I thought I’d ‘tinker’ again, at least I got cable working and can use the 'net again and start getting to know PureOS BEFORE blowing $2k± on a laptop that might work for me. Remember/update/reminder that I wanted try out PureOS that comes on the Librem 15 to see if at least the 15, I, and OS are compatible.

I’m sure L-15 will have a very nice, and buggy-free Wi-fi. Now I can at least play with PureOS cabled again.

FYI: I intend to remove MINT and just put PureOS on here (again), and use it to get use to PureOS until I save enough for the Librem 15. Almost there.


Perfect, sounds good! You did it (hit it with needed Ethernet driver)! Perhaps I’ll (or someone else) be back to you related to Wi-Fi card (that you might want to replace), but not now.

No, nothing would be left behind, as new OS installation is just like a new week, new start.

As you want (insist) to have working hardware on your TOSH laptop with PureOS that includes non-free firmware you need to read carefully this chapter (second paragraph) about Debian’s /firmware folder. That’s why I told you to install Debian (link above to amd64-DVD-1.iso, one option would be to replace MINT and compare two /firmware folders, one with all HW working Debian automated installation and the other with only partially working HW after PureOS installation).

Besides, I thought you were already asked to post here following output (print of some errors in red / missing .bin files) from PureOS:

sudo dmesg (like = firmware: failed to load) and

sudo lspci | grep -i wireless,

yet might not choose above explained approach (but still lessons to be understood/learned) to solve this issue with non-PureOS HW and do an install with optional step-by-step method (includes needed non-free packages).

As you are having now working Ethernet connection (Internet from within PureOS) let us go back to another experimental work(around) by using apt or aptitude package manager:

First you need to edit (as sudo/root) /etc/apt/sources.list and add following line(s), first one isn’t optional:

deb stable non-free
deb buster/updates non-free (optionally)


sudo apt update
sudo apt upgrade

Now you might download debian-archive-keyring (optional, not necessarily).

sudo dpkg -i debian-archive-keyring_2019.1_all.deb

Finally, execute following:

sudo apt update && sudo apt upgrade
sudo apt install firmware-linux-nonfree
sudo apt reinstall firmware-realtek
sudo update-initramfs -k all -u

Afterwards you might be able to:
sudo apt install firmware-whatever-needed in order to avoid W: Possible missing firmware error when running:

sudo update-initramfs -u

Also (still helps somewhat), very similar not connect Wi-Fi issue that wasn’t resolved:, but you might persist on trying to resolve yours.

And, I admit that your late in the night questions were for myself pretty much out of the blue.

P.S. By the way (sorry), hostapd is absent in PureOS repository and therefore leave it aside, please. And, if not used at all (from your side): sudo apt purge cryptsetup-initramfs (but it might be linked to some other packages, who knows :roll_eyes:).

from this i assume that you have a very specific reason why you need a laptop. if not you may very well discover that the Librem Mini does it’s job well enough at 700 dollahs. you could grab an iNUC for a fraction of that cost if you’re to mess with non-free-firmware …

Hi @reC,

Specific use depends on COVID-19(84) and whether or not, and when, countries will open their borders, businesses return to their offices, the world-wide economic machine is churning again, and I don’t lose everything by then. I’ve lost friends, lovers, and of course virginity, but nothing compared to what this maddemic has stolen. :worried:

There is no sense increasing payables right now until receivables start a healthy receiving again.

1 Like

Here is my output (as already recomended in this thread):
sudo update-initramfs -u -k all
update-initramfs: Generating /boot/initrd.img-5.9.0-5-amd64
update-initramfs: Generating /boot/initrd.img-5.9.0-4-amd64
W: Possible missing firmware /lib/firmware/ …

I mean under (perhaps) /lib/firmware/rtlwifi/ in accordance with this post (last one) and this link (if corresponding to your WiFi card).

To be sure which WiFi card is built-in, from this orientation link:, you might execute:
sudo lspci -nn | grep Network

As well you might edit/add this repo (with or without main) to your sources.list as described here:

by adjusting/including above post up to this Debian link here with non-free.