Cannot drop into virtual console on Librem13v3

Hi, I just received my Librem laptop and set up the account information. However, when trying to personalize my laptop I realized that I couldn’t drop into a terminal view (virtual console) from the login screen or the desktop (after login). On other Linux OSes the keyboard shortcut is Ctrl + Alt (+ Fn) + F1 but this doesn’t work. In fact, all it seems to do is freeze my mouse until I execute the keyboard shortcut again. This seems like a bug and not just an issue where I have the wrong shortcut. I tried Ctrl + Alt + F7 as well as Alt + F2 and both of these freeze my mouse as well until I enter the keys again. Perhaps the terminal is executing in the background and just not getting brought forward?

Haven’t been able to find any solutions to this, does someone here know what I need to do to fix this?
Thank you

As far as keyboard shortcuts I’m not sure. But the app you are looking for is called Tilix in PureOS. Just hit the purism key and type that.

The Tilix terminal works fine, but you have to be logged in to access it. I need to be able to drop from GUI to a terminal before logging in. Every other flavor of Linux is able to do this as far as I know, with the shortcut Ctrl + Alt + F1. When dropping to the virtual console, as its called, you aren’t logged in so it’s not a security vulnerability, so I don’t see why it would have been disabled in PureOS. Plus, when using the keyboard shortcut, the mouse freezes which means this has got to be a glitch.

My current use case for using the virtual console is that I want to change my username, and you can’t have any processes running on the user when using usermod. This means I need to drop into a virtual console, su to root and then run usermod. Im sure theres a workaround to change my username another way but even so I would like the virtual console to function properly if I need it later.

I figured it out, and the reason was really stupid.

See, on some laptops (ie the one I used previously) you must use the Fn key to access the F1 - F12 function keys. On other laptops (ie Librem), F1 - F12 is default while Fn gives access to the alternative functions. So, when I pressed Ctrl + Alt + Fn + F1, the computer interpreted the command as Fn + F1 which JUST SO HAPPENS TO BE the “disable mouse” button. So that’s what was causing the mouse to freeze.

Of course, I had tried Ctrl + Alt + F1 too and nothing happened. Unless I’m mistaken, normally Ctrl + Alt + F1 drops to virtual console and Ctrl + Alt + F7 leaps back to GUI. Turns out on PureOS it is the exact opposite, Ctrl + Alt + F7 drops to console. I said I tried this in my original post but I must have actually only tried Ctrl + Alt + Fn + F7 which is just Fn + F7 (NO clue what that does). The important thing is, I fixed a non problem.

For anyone who is wondering, dropping to console view with Ctrl + Alt + F7 will work but nothing you type will be interpreted. After dropping to console you must Alt + F2 to bring up a login prompt. Now you can log into any user, root for example, and run commands.