Cannot find libdpkg-perl_1.19.7_all.deb

I need some help, please. I want to install pkg-config. So, I try.

$ sudo apt-get install pkg-config
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
Suggested packages:
  debian-keyring bzr dpkg-dev
The following NEW packages will be installed:
  libdpkg-perl pkg-config
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,414 kB/1,478 kB of archives.
After this operation, 2,695 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
Err:1 amber/main amd64 libdpkg-perl all 1.19.7
  404  Not Found [IP: 443]
E: Failed to fetch  404  Not Found [IP: 443]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I can see that SOMETHING exists with a “pureos1” suffix on it at

As a matter of fact, everything in the dpkg directory has the “pureos1” suffix on it.

I found this documentation on the PureOS wiki.

Packaging Overview (

It describes the reason that the “pureos1” is on the package name. However, it does not describe how to use those packages when trying to run something like apt install dpkg-dev which fails due to the renamed packages. So, maybe this is an apt or dkpg issue that I’ve got to figure out?

I’m new-ish to this PureOS thing. I come from an OpenBSD background. Sorry if these are n00b questions.

Did you run sudo apt update before trying to install?

Adding the “0pureos0” string to the packages version number is merely the way Debian derivatives are asked to name their derivative specific packages. You’ll see 0ubuntu0 packages named similarly as well. This should have no bearing on whether or not you can install a package, just the package’s version number.

Yes, I did, @mladen. Thanks for checking on that.

@jeremiah, thank you for the insight into the naming scheme. I appreciate that. However, it does seem to have some bearing on the installation.

1 Like

Well, you’re right of course. What I suppose what I ought to have said is that the tools that do dependency solving should be able to understand any suffix, like “pureos” or “ubuntu”. If they don’t that is a bit of a bug.

Were you ultimately able to install the package?

I just tried this same package install (apt install pkg-config) and ended up with the same result as @realistschuckle I then edited my /etc/apt/sources.list file to look like this;

deb amber main
deb amber-updates main
deb amber-security main

then I re-ran sudo apt update && sudo apt install pkg-config and everything worked for me. Please let me know if that doesn’t work, or even if it does.