Cannot register new 2FA token with forum

Currently this forum shows a message with “Internal Server Error” when I attempt to register a new physical security key to my account for two-factor authentication, and the registration of the key does not complete.

In addition, the box for typing in the name of the key is pre-filled with the text “user.second_factor.security_key.default_name”.


OK, did this ever work or is it a regression?

1 Like

Good question. The answer is that it used to work.


Well, if I had a physical security key, I would attempt to reproduce this for you …

What make/model of widget, for example, would I need for this?

@JCS I guess this needs to be escalated.

Yes, I see that too.

1 Like

I’m able to register a physical security device (Nitrokey 3C NFC), however, I’m unable to log in with it because the server is returning an HTTP 500 status code. Thankfully, I still have the TOTP 2FA method.


Another data point: Logging in with a hardware security key still works for me, the registration flow for a new key gives me the same user.second_factor.security_key.default_name as reported above. I did not try to run that flow to completion.

I have more than one security key registered, so adding more keys has worked in the past.

1 Like

I created an issue for the sysadmin to review.


I tried adding an additional key, but I also tried removing the existing key so that the key I was trying to add would be the only registered key.

I physically lost my existing key, so I don’t know whether logging in with it would have worked.

I attempted to register a Nitrokey 3A NFC.

1 Like