Can't access NVME drive when booting from USB or SATA (Librem Mini)

I just bought a Librem Mini (v2), and I followed the normal setup installing to the NVME drive that came with it using disk encryption. I seem to have misremembered the passphrase, so it can’t boot from the NVME. I want to set up a new OS install on the NVME drive, but I always run into the same problem:

  • If I start my machine with the NVME drive inserted, then it will boot from the NVME no matter how quickly I spam ESC.
  • If I start my machine without the NVME, then I will be able to boot from USB or SATA, but will not be able to access the NVME even if I reinsert the NVME before GRUB exits.

How can I install to my NVME drive?

Possibly Relevent:

  • I have tried with a GUIX and a PureOS iso (both downloads were verified) across multiple USB ports, USB drives, as well as an SSD over SATA.
  • The only NVME port I have access to is the one on the Librem Mini (I can’t write an ISO to the NVME drive somewhere else)

If you can get to the console of your USB installer, the drive might appear after you do:

sudo sh -c "echo 1 > /sys/bus/pci/rescan"
1 Like

Thanks for the reply. Unfortunately, that made no change. I:

  • removed the NVME drive
  • reached the ISO’s GRUB screen
  • reinserted the NVME drive
  • booted into ISO OS
  • ran sudo fdisk -l (only showed USB and SATA devices)
  • ran sudo sh -c "echo 1 > /sys/bus/pci/rescan"
  • ran sudo fdisk -l (still only showed USB and SATA devices)

I don’t have a Librem Mini so I can’t contribute much, but I did see this post in another thread mentioning that pushing ESC more than once causes it to boot the default. Is it possible that you have been hitting it multiple times every time you have tried to access the BIOS/UEFI interface?


Oh my lord, you are a lifesaver. Thank you very much.