Can't boot Librem 14 from PureOS Live on USB drive


I’m trying to boot my Purism Librem 14 from a USB drive where I burned the latest PureOS using Balena Etcher, as recommended.

When I boot, I press the Esc key, go into Boot options and select USB boot. Then it shows the different booting options of the USB drive: test and install, live boot, etc.

I select one of the 2 live boot options, but then it just goes into a shell. I took a picture of it:

I tried the other physical USB port. Same result.

Any solutions?

1 Like

It should work, but I need more details about the USB drive:

  1. Model name and capacity
  2. PureOS version (either 10.3 or 11)

If you flashed 10.3, try flashing it again or 11 (Crimson) instead.

If it still does not work, check that your version of PureBoot is up-to-date.

That pathname looks unusual - although it is difficult to read exactly what it is.

Do you have a flash drive with an earlier version of PureOS for live boot?

1 Like

The problem was that the USB drive was too small for PureOS. And I think I used Unetbootin after Balena Etcher gave me a blank window.

It’s solved now. Thanks.