Can't connect to WiFi outside of my home

Hello everyone!

I have been using my Librem 13v2 with PureOS normally for a while, but today I tried to connect it at school and found out that the internet wouldn’t work.

I tried Eduroam, the school’s open WiFi and even my phone’s hotspot. With Eduroam I got what I think is a deeper issue (it wouldn’t connect at all and kept asking for my password). With the other methods the WiFi connected and reported good signal, but I couldn’t access the Web.

PureOS gives me a Server not found error and Chromium gives me This site can’t be reached. I don’t use firewalls or proxies.

I haven’t changed anything, but when I came back home the internet worked again.

Any ideas what the problem could be? Am I missing something?

Thanks in advance,


Hi @regisfrias,

I believe Eduroam needs some certificates added in your trust store in order to work. Did you download these?


I followed the school’s procedure for using the network and it should all have been correct.

Anyway, that doesn’t explain why even the open WiFi didn’t work :frowning:

Run the command cat /etc/resolv.conf while at home and at school and see if they differ. Some school networks don’t allow for DNS servers other than theirs, so you may need to see if that is an issue. One way to do this is to go on a device than can connect to the internet on the school’s network and do the test here. If the DNS servers that show up on that device are different than the ones you have, you’ll need to either set them to the given addresses (editing /etc/resolv.conf as root) or, if that doesn’t work, find some IT staffer to tell you the local IP address of the local DNS server so you can put that in for /etc/resolv.conf.

Here is an example /etc/resolv.conf:

domain lan
search lan

Maybe gnome has some network settings that disallows the network to make changes to the clients DNS? I don’t know.


thanks a lot for the answer, @AnameIneed!

Maybe gnome has some network settings that disallows the network to make changes to the clients DNS? I don’t know.

This seems to be the case, here’s what I get from the command you suggested:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)

But regardless of that, this wouldn’t explain why I can’t connect to my phone’s hotspot. I tried it at home and had the same result: the house WiFi works, but the phone’s hotspot doesn’t work. It connects, shows strong signal, but the browser says Server not found.

I’ll try the resolv.conf later at school as well, but even if I do get different results as you suggested that still doesn’t account for the behavior of the phone hotspot :stuck_out_tongue:

It appears as if your /etc/resolv.conf is not updating, check your /etc/NetworkManager/NetworkManager.conf file too see if there’s perhaps “dns=none” option activated.


thanks for the reply!

This is the full content there now:



@mladen a friendly bump :slight_smile:

Given the content of debian wiki’s NetworkManager page, I would suggest to:

  • Ensure your wireless interface is not present in /etc/network/interfaces (your interface probably is wlan0)
  • Set managed=true in /etc/NetworkManager/NetworkManager.conf
  • Restart NetworkManager by typing /etc/init.d/network-manager restart

Thanks @thib for the quick reply!

My /etc/network/interfaces only has this:

# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

Then, /etc/NetworkManager/NetworkManager.conf is so:



And I restarted network-manager as you suggested, but still unable to connect to the internet from my phone’s hotspot :frowning:

Did I misunderstand something? Should the interface be or should it not be present in the file?