Can't figure out reflashing librem 5

You have to leave Chats open, swipe it up to reveal the app grid, open Usage, scroll down until you see “Chats,” tap it, then force-quit it.

1 Like

Failed. I got what you meant. And no changes.
Maybe if I delete uninstall Chat/* power off, turn it back on and reinstall it again?
I know, I’’ lose everything. One thing I did right was not to put anything important on it.


Potentially harmful. I just tested (without following through). Removes additional essential packages at the same time. I wouldn’t do it.

1 Like

There is a suggestion @ carrier that I remove and reinsert the Sim card.
But none of the Google hits and instructions say if the phone power should be on or off.

1 Like

With the L5, you run the risk of frying the SIM card if you remove it or insert it while the phone is on.

Question: Is there no back arrow button on the initial Chats screen that you see? If there is, then that would take you to the main screen of Chats. I’m guessing you don’t have that, though.

Here’s something you can try, if you know the MMS settings for your carrier:

Inside the Files app, show “hidden” files (from the hamburger/Preferences menu). In your Home folder (i.e. “Purism”) you should now see a folder named .mms. Open that, then open the “modemmanager” folder, and look for a file called “mms.”

Open it, and you can edit a couple of lines to match the settings your carrier (hopefully) gave you. The lines are “MMSC” and “MMS_APN.” (I think that’s all you need to enter.) This is equivalent to typing it directly into the Chats app.

Save and close the “mms” file. Now see if Chats is behaving for you.

That might work for iPhones or Androids, but not the L5. It requires you to manually type in the settings (for MMS). It would normally work for calling settings, though.

1 Like

By the way, this is all about MMS picture messages. Regular SMS text messages should already work if you’ve entered your carrier’s APN settings in Settings > Mobile (main L5 Settings app). (Or if the settings were populated automatically based on the inserted SIM.)

1 Like

You nailed it. The preferences are in the “Chats” list of texts showing names beside Chat title.

It use to work. WiFi that is. I can send/receive texts that goes through ‘Mobile’.

I’ll have to check w/ Koodo to see what their new settings are. Isn’t upgrades nice :grinning:
I turned off Automatic and it gave me a list of carriers. Koodo is on that list. I chose it (“Set”) but WiFi is still dead.

Perhaps I should just do the Flash first, but hate to do that to find out Koodo won’t work.

Another day…

1 Like

So by Wifi do you mean Cellular Data or actual Wifi from a router?

1 Like

They mean Cellular Data.

The Librem 5 doesn’t have WiFi calling or texting capability (at least currently).

Do you mean that you do have the back arrow present, or that you don’t?

Given the number of problems you have had with your L5, it’s probably worth it to start with a fresh reflash. It will erase everything you’ve set up, though. Koodo should work as well as any carrier (whose frequency bands match the L5’s modem), but not for WiFi calling/messaging on the L5, as I said.


Suggestion to Puri, list what does work. It’s faster to read than what doesn’t work.

Yes. The back arrow takes 15 - 20 taps to register, but yes, I could use it to go back, and Yes I could see and use the Preferences.

Yeah. That seems to be the answer and for me, a complicated one and may only tell me the phone is too old to be of any use and I don’t like paying a monthly fee for that…
I read where others re-flashed into a nightmare. Scary.

I’ve decided to see if someone can do it for me, AFTER I get it straight with Koodo, a Telus minion, what their settings are today.

A very long day today trying to find out what their settings are to be.
Thanks Amarok

1 Like

Normally, the L5 would automatically fill in the Access Point Name settings that correspond to the SIM card that is inserted. If it doesn’t, manually add them as below.

According to a very recent post I see in the Koodo community forums, this is probably all you need to do:

Go to
Settings > Mobile > Access Point Names

If you don’t see an entry for Koodo, tap the “+” at the top right of the screen to add the following:

Tap Save.

If you do see an entry for Koodo already there, tap the gear icon and make sure the pre-populated APN settings are correct. Change, if necessary.

Next, go to

Settings > Mobile > Network

If you don’t see an entry for Koodo, disable “Automatic” to trigger network searching. If it times out before it finds Koodo, tap the circular arrow to keep searching.

Once Koodo is found, select and set it.

Next, open Chats, select Preferences from the “hamburger” menu, then SMS and MMS Settings.

Enter the following in the given fields:

Phone… (I’m not sure if it’s necessary to enter your phone number.)

(You can’t see the entire string in my screenshot below, but it’s there.)



That should do it, unless Koodo has given you settings different from those above.

If that does’t work, I recommend starting a new topic, as we’ve already strayed from the original post.

P.S. You also need to enable VoLTE (Voice over LTE) calling:

Open the BM818 Tool app.

(If you don’t have it yet, open the terminal and install it with the command: sudo apt install bm818-tools)

Check the box:

Then restart the Librem 5.


Very carefully ensured I followed your excellent Step x Step, what could go wrong - right?
I get:

I have recently finished flashing the phone - now may I get dressed.

Perhaps, I should flash it again because, Chat shows loads of identical texts w/ same image to same contact. Flash removed all contacts (this is good) I am addressing these in my other post that dealt width flashing.

Texts get sent and received. Text w/ pic, doesn’t go. No note saying so.

Does the X in a red circle mean anything? Example:

Well, I tried to get a example of the device, but when wanting to send a text w/ pic, no matter what I tap on as my pic to send, and tap “Open” it opens the one at the very top, not any of the images in the list I highlight.
That aside, I made this pic so it would be at top of file list:

I guess I could have shrunk the image to fit here better. Sorry. Too, maybe the mod will want to move this to ‘Post re-flashing blues

1 Like

Does it still show “Failed to get Modem FW version” after a reboot?

Question for anyone who has reflashed recently:
Did the build include the latest modem firmware (09/2022, I think), or did you have to update it separately after the reflash?

@Sharon , if the problem is still there, I recommend contacting Support.

Possible temporary lack of data connection, maybe. (Unless the MMS setting is incorrect.) Have you tried again?

It’s not clear to me where you’re seeing this.

1 Like

The red x is merely there to let you cancel sending the picture before you hit send if you pick the wrong one.

Are the apns in in the chatty settings and the mobile settings different or the same?

In mine:
Settings → Mobile → Access Point Names:

Chatty → Preferences → SMS and MMS Settings:

1 Like

No. After the 3rd time having powered off at night 3 times since the issue

It’s been like this since right after the flash - March 26/2024.
Add to that, after the flash, I expected all the Chats would be gone. If I enter a text and send, and after boot, come back the next day, there are about 25 copies. It grows by leaps and bounds. I must manually delete the entire list.

ASwyD2 answered that:

Thanks Amarok
always appreciate you’re being around,


Yes, both are the same APNs - but something keeps adding them. I started with 1, but today there are 5 of them.

Thanks ASwyD2


If uninstalling/deleting Chat is not a good idea, am I stuck with Chat indefinitely?. There might be something that does work property to take Chats place and would be no sense it taking up space. As it is, it’s useless and just costing money doing nothing.

1 Like