Can't get gPodder to work

I’ve tried to get gPodder to work on the Librem 5 but for the life of me I cannot get it to point to the folder I created specifically to store podcasts under the device tab and also the audio and video dropdowns in the general tab only say default device even though I have vlc installed and they present no other options. I’m thinking I’m missing something or something isn’t installed correctly.

That states that the video player is the default video player on the system. I would check under;
System settings > Default applications
And check what is the default for videos. And if it is not VLC change it to that.

When I try to set the media folder after selecting filesystem based, I get a “operation not supported the folder contents cannot be displayed”

When I try to browse to the folder i created to store podcasts, I cannot find it. Is it a permissions issue? Its a symlink to my sdcard.

In that case it is probably a case of: don’t do that.

Can’t you just use the uSD card directly? Or do a bind mount if you have to for some reason.

I thought doing bind mounts of home folder is problematic?

I did symlinks on folders inside the home directory, not the entire home directory as i know that can cause problems. Should i do individual bind mounts for each directory instead?

@raenrfm but where you at least able to set the video player you wanted?

vlc does not show up in the dropdown even though its set as the default app globally. The gPodder docs say that in linux version you should see a list of apps in the dropdown that can be used for playback. I’m thinking i might re-install it.

how did you installed it. And did you checked in the PureOS system settings what is the default app for video?

Its set in system settings and I believe I installed from the app store.

I think I’m going to try a different podcast app, I cannot get it to use the directory I created for it…it insists on using /home/purism as the folder, I cannot direct it anywhere else.

hmm…it’s also not saving any of my preferences.

I’m thinking now it might be the flatpak version that is causing the problems.

So I re-installed it from command line using apt and I got a version that is actually adaptive and also I was able to select the proper audio and video players. I think the version in the store through the gui is wrong because I kept installing the gpodder-adaptive version through the gui and that caused all kinds of problems. As for the default download directory that still didn’t work, even after editing the Settings.json file, so what I did was just created another mount of the Download directory inside the gPodder folder…bob’s your uncle it’s working now.

Do you have flathub repos added? That might explain that. Maybe you installed the application from flatpak instead of the one in the PureOS repositories.

I was assuming you installed from the PureOS repositories. I should have asked it first.

Yeah my bad I have the flatpak installed.

If you are interested we have this non-exhaustive list of apps that are mobile optimized and available in the PureOS repos:

I would add Brave to this list it works much better than Firefox even though it’s not optimized.

Brave browser is not available in the Debian repositories and consequently not in pureOS.

Ah gotcha.