Can't login when Gnome with Xorg is selected

I can’t login on my Librem 14 if I select Gnome with Xorg from the options on the login screen. It works with regular Gnome, but not with anything else I’ve tried so far, including the default. I read in a previous thread where somebody else was encountering issues like this, and apparently it was due to a faulty update. Is it the same issue here? If not, I’ll walk you through what I’ve done up to this point.

I noticed after setting up my Librem 14 that there was a limited software selection. A lot of things that would be useful to me personally, like media codecs, were not included and didn’t seem to be available in the repos. I assume it’s because they’re proprietary. To mitigate this, I started looking into how to add more repos that I can draw from. So I added the Debian Bullseye repos to my repo list. I noticed after applying updates that the Debian packages were modifying parts of the OS itself. I wasn’t aware this would happen. So after reading about this same issue in a previous thread, I added a settings file to pin the PureOS repos. I set the Pin-priority to 1100 to force it to downgrade back to the versions that were in the PureOS repo, and this seemed to work for the most part. I still see a Debian logo off to the side of the password screen for decrypting the drive. But other than that, it seems to be behaving properly. I changed the Pin-priority to 900 after that so I would have the option to install from the Debian repos in the future if I so wished. I’ve since put this project aside to focus on getting other things working.

I have an XP-Pen Artist 22 display tablet I’m trying to set up. Testing it out of the box, I found that it moves the cursor on the laptop screen instead of the tablet screen, and it also creates a second cursor. I’ve tried looking up tutorials online on how to fix this, but all the ones I found direct you to use xsetwacom to configure the tablet. However, it doesn’t seem to be detecting my tablet. At first I tried installing the DIGImend driver, but that didn’t make a difference. After doing some research, I added the below custom rule to X11:

Section “InputClass”
Identifier “XP-Pen Artist 22 Tablet”
MatchUSBID “28bd:092f”
MatchIsTablet “on”
MatchDevicePath “/dev/input/event*”
Driver “wacom”
EndSection

now this didn’t fix the problem, but it did do something at least. Now the right-click button on the stylus works, when it didn’t previously. The other problems remain, though. After some more research, I found the problem is likely because PureOS uses Wayland by default to handle inputs. It sounds like the solution is to switch over to using Xorg. But again, I can’t seem to select that option. It just boots me back to the login screen when I try selecting that. I don’t know if it’s something I did that’s causing this, or if there’s some other issue that’s causing it like a faulty update.

I’m pretty new to the Linux world, so I’m learning all this as I go. Getting this tablet display working would be a big step toward switching away from Windows for me. So any help would be greatly appreciated.

Update: I’ve solved the problem. It was the custom X11 rule I added that for some reason caused Xorg to stop working, so I removed that. What I did instead was add the USB ID to the existing 50-digimend.conf file, and that fixed the issue. I was then able to use the xsetwacom MapToOutput command to align the cursor to the correct screen.

Hope this helps anybody else trying to get a tablet display working.