Can't Navigate To Mount Point of Encrypted Drive

I’m trying to navigate to the contents of the internal storage drive using the file explorer.

I encrypted the drive using Luks.

After mounting the drive, I run lsblk -f in terminal. The drive shows mounted at “Storage2”.

Using the file explorer as root, with hidden files visible, I can’t seem to navigate to the Storage location.


…doesn’t show anything.

Searching the entire computer doesn’t show any hits for “Storage2”.

Decrypting using terminal shows no errors. The drive decrypts & mounts. I just can’t find it in file explorer.

Any ideas what’s going on? And how to fix?

Perhaps /dev/ shows storage2/.

/dev/mapper/Storage2 shows the link to the block device. But it shows it at as empty.

All the other mounted drives show under “devices”, just not Storage2.

lsblk -p /dev/sdX

$ lsblk -p /dev/sda
/dev/sda 8:0 0 931,5G 0 disk
└─/dev/mapper/Storage2 253:3 0 931,5G 0 crypt

1 Like

I’m not expert on encrypted drives but I see no partitions? How about:
$ ls -Al /dev/sd* or perhaps $ ls -Al /dev/nvme*

$ grep -srl DEVTYPE=partition /sys/devices

No need to publish any output here but, as said, I see no partitions within your post/output and doubt that can help any further (as it is too late for me now, although I like to learn something here).

Thanks. Grep command doesn’t see the device.

I’m wondering if cloning the drive to an external device, then mounting on the external device would get the file system to see the mounted, decrypted data?

At this point, I just don’t know what to do. The data is there. The drive mounts. I just don’t know how to get the file system to see it and allow me to navigate to it. (Nor what might have messed it up.)

I cannot help right away (but hope your data is still there).

Please let us know if you see related partition(s) with fdisk or parted -l, when drive unlocked, but drive/partition still not mounted (data visible) yet:
sudo fdisk --list
sudo fdisk --list /dev/XXX

Did you already booted into a Live Environment (if you can open/read this Luks drive)? Also, if you are using Nautilus do you have seahorse-nautilus package installed? Which filesystem(s) are on this drive/volume?

No need to answer above, yet please read (it is mentioned twice) and follow: “Make sure that the block device to be decrypted has not been opened by cryptsetup (there is no entry under /dev/mapper/, let alone mounted). If it has been, unmount and use cryptsetup luksClose to close it.