Can't receive phone calls anymore

Hello everybody,
my L5 was doing great, but in the last weeks I got this new problem: I can’t receive calls!
I can make calls, send and receive sms, use the internet… But every time my family tries to call me I just get the SMS from the carrier, telling me that somebody tried to call me + date and time…

Is there anything I need to check?

Did you enable suspend by chance? It’s not fully ready for general use yet.

No unfortunately it’s not enabled, I tried it for some time but I had some troubles and decided to avoid it.

Is there anything in particular about the network you’re using or the network that your family is using during the calls that could explain the problem?

I wish my carrier did that!

1 Like

Are you using VoLTE?

No I don’t think so, I tried with different carriers and the result is still the same. Plus it worked wonderfully before :frowning:

My settings say: “2G, 3G, 4G (preferred)”. During phone calls I’ve always seen 2G.

That means you’re not using VoLTE. Otherwise it would remain on 4G during calls. Your issue could be that your carrier is making changes to their 2G network, affecting your coverage, but that’s just a guess.

If you haven’t already, install the BM818-tools app (sudo apt install bm818-tools), launch it, and enable VoLTE to see if that helps.

VoLTE isn’t yet required on every network in every country, but carriers may have already started evolving their networks in that direction. In the U.S., VoLTE is already a hard requirement.

I installed the package, but the checkbox is disabled again every time I exit the app.
I’ve also noticed that it says “Failed to get Modem FW version”, I don’t know if it’s normal :smiley:

Maybe a reboot will fix it. Are you sure you have a network connection at the moment?

Yes, I tried to call and use firefox. I checked the output of:
mmcli --modem=0
and it seems that my modem firmware version is dated [Nov 26 2020 02:00:00], is it something I need to update manually?

I don’t know if that’s recommended, but you can ask @dos.

1 Like

Better to ask Purism Support

1 Like

Hi @rekotc !

I had this behavior after a few updates about a week ago. After a restart everything worked again, but after a few minutes it was again not possible to reach me by phone. At the moment I don’t have the problem anymore, maybe an update in the meantime solved the problem.

I contacted and they helped me solve my problem. I had an older firmware on my modem, they gave me the instructions to update, and it worked like a charm :slight_smile:
I’m not sharing those instructions here only because they involve updating the modem firmware and I think it’s better if you do it while being followed by their official support.

thanks everybody!


Would you mind posting your latest modem firmware version? Thanks.

Sure, I have the E1 (Europe) Version. This is the output of bm818-tools:
FW Version