Can't restore disk image

Hi, I’m following the steps below to update my Librem 14 EC firmware.

In these steps, I have to restore the ISO image to a USB device.
My USB stick is 1.7 GB, and it gives message

the disk image is 31 GB smaller than the target device
I choose Restore and it seems nothing happens.

Any advice?

Are you choosing the correct USB device (the USB stick) and not something else?

I usually find it a good idea to look at what USB devices exist before I plug in the USB stick and then look again after I plug in the USB stick, to see what changed i.e. new devices - so that I am sure that I am going to write to the correct device.

The assumption is that the USB stick is going to have its contents obliterated by this operation, in which case … does it already have stuff on it? and if so has it previously worked normally on this computer?

Maybe posting a screenshot from Gnome Disks would help.

Yes I have made sure that its the USB stick I’m selecting.
There was data on the USB stick originally but I deleted it first.
Here’s a screenshot

Then I am struggling to see how

can be true.

Your computer thinks that it’s a 31 GB USB stick. Can you clarify? A photo of the USB stick? Many (but not all) USB sticks will be marked with their capacity.

Also, did your download of the .iso file work correctly‍??? Your computer is saying that the .iso file is only 84 KB (which is surprisingly tiny - please confirm the size) but when I checked yesterday I thought it was more like 200+ MB. And that’s kind of what Gnome Disks is trying to warn you about, albeit that you are still going to get a warning anyway.

Also I am wondering what “Generic STORAGE DEVICE” (of unknown size) is. Hopefully it is not relevant here.

It looks like the latest Librem_14_EC_Update.iso is 277.00MiB in size. @chucker8, please try to re-download this file and let us know what gnome-disks reports as the image size of the file.

Purism ought to publish securely a cryptographically-secure hash of the file so that one can verify the integrity of the file after download and before doing anything with it. However the difference between 84 KB and 277 MiB ought to be clue enough not to bother with checking the hash. :wink:

@chucker8 I just read this in the README, one level up in the repo :flushed:

The files in this repo are not intended for end users.
They are intended to be used by official Purism update
mechanisms (eg, coreboot utility script), or downloaded
and applied manually when directed by Purism support staff.
Direct flashing or other use by end users without specific
instruction to do so is highly discouraged.

@irvinewade It would be trivial as-is to provide a checksum as a text file in the repo. If these files are later generated as CI build artifacts, it would be easy to modify the yml to include the checksum as part of a release without any human involvement.

Ok, turns out I downloaded the link to the .iso image and not the image itself.
They each have the same file extension?
I was able to restore to disk.

How do I boot from this USB now? I tried hitting the Esc key during reboot but nothing happened

Are you using Coreboot or Pureboot?

If the former, I think you need to press Esc quite early (when the logo appears?).

how do I tell if I’m using Coreboot or Pureboot?

I don’t know.

What did you ask for when you bought the Librem 14? Do you have a Librem Key dongle?