Can't Use gnome extensions

Hi, trying to install gnome extensions on L15 with latest PureOS and am told I am not running Gnome…but I am (ver 3.38)! Has anyone else had this problem? Help will be gratefully appreciated.


Just open Terminal application and type:
apt list gnome-shell-extensions

If this package not already installed please type (execute):
sudo apt update
sudo apt install gnome-shell-extensions

Did that. System lists no extensions but when I install it tells me already installed? Here is the error message I get from the Gnome Extensions Website: " Although GNOME Shell integration extension is running, native host connector is not detected. Refer documentation for instructions about installing connector.) The documentation refers to Chome. I’m using Firefox and the browser that came with Pure.

1 Like

Sorted. Installed Chomium and all is good. not sure why it would not work with Firefox though?

Please let us know if this helps under Firefox (of yours):
sudo apt full-upgrade
sudo apt reinstall chrome-gnome-shell
sudo apt reinstall gnome-shell-extensions

Same issue more or less explained here:

Thanks for your help!!!

1 Like

Hi people, I am running Firefox (Flatpak version) on PureOS 10.0 and I have the same problem on my Toshiba laptop :frowning:

I have tried Quarnero’s steps but to no avail:

I was running Debian 10 & 11 previously and never had this issue on Firefox (standalone version).

Can anyone help? (I would prefer continue using Firefox-flatpak)

Info (for your own reference/research):, as renamed to gnome-browser-connector.

Even perhaps (while I’m not using it) with here (probably) related version 105.1 this add-on helps (?):

I can be wrong but as far as I know, gnome extensions do not work with flatpak applications.

1 Like

Thank you for your message @Quarnero, I had already read these webpages.

Thanks for your message @joao.azevedo. So I tried with another browser, the Chromium Web Browser from pureos-byzantium-security-main and now Gnome Extensions is saying this :man_facepalming:

Your native host connector do not support following APIs: v6. Probably you should upgrade native host connector or install plugins for missing APIs. Refer documentation for instructions.

Any help, anyone? Or should we just give up installing extensions for Gnome on PureOS :sweat_smile:

Same on Firefox ESR:

did you installed the firefox addon: GNOME shell integration

I am not sure if it also exists from chrome as I do not use chrome/chromium