Change language in Librem5 in qemu

I can’t figure out how to change the language in Librem5: dpkg-reconfigure locales doesn’t work. Does anyone know how this is done?
Thank you

You can use: sudo nano /etc/locale.gen to comment out the languages you want to add them. Then do sudo locales-gen

After that go to > Settings > Languages; and add you should see the language options available, and add a new language.

After that reboot the image.


thanks very much
best regards

hi and thanks for the help.
I note problems.
with sudo he asks me for the password but he does not recognize me as root (as a user I have not set one). For root i have set a password.
I changed the /etc/locale.gen file as root.
at startup it no longer shows me the settings screen (as in the image you sent).
What mistakes do I make?
Thank you.
P.S. i use debian stable and qemu image 1981
P.S. i change passwd ad user purism and now the passcode at access dont work

ok, now work. i have change the password for purism for use “sudo”.
best regards

no, sorry, the passcode at access dont work (123456).
i have changed password for user purism and root. i dont understand this problem


  1. sudo nano /etc/locale.gen (password user - purism - 123456)
  2. sudo locale-gen

  3. bye and thanks

Actually, I’d be more interested in getting rid of unwanted installed languages, (Just to save space.) I went through an hour or so the other day on a linux Mint machine in synaptic picking and choosing language packages just to get rid of them.