Chromium crashing after launch (fresh install)


#1

got my Librem 13 not log ago, so far giving it a try with PureBrowser but want to check out Chromium as well.

just after a fresh Chromium install, it immediately crashes after launching. Anyone experienced similar issues?


#2

Is everything up to date?

sudo apt update
sudo apt upgrade
sudo apt dist-upgrade


#3

Thanks, beFree. That works!


#4

thanks for the tip beFree, I had to download a ton of updates. Wondering why they didn’t show up in the “Software & Updates” and I had to force them through the terminal?

Unfortunately the Chromium behavior remains the same…


#5

Hi @dakshinachara,

Can you open a terminal (launch the application called tilix on your Librem), and launch Chromium from the terminal? Simply type in chromium from tilix

There should be a lot of text in your terminal before Chromium crashes. Can you paste it here?


#6

:~$ chromium
Gtk-Message: Failed to load module “canberra-gtk-module”
Received signal 11 SEGV_MAPERR 000000000010
#0 0x5634125dbf56
#1 0x5634111a8a58
#2 0x5634125dc2dc
#3 0x7f27302bcf50
#4 0x563411acd5ba
#5 0x563411ace43d
#6 0x563411acea4d
#7 0x563411acebb5
#8 0x56341263ff19
#9 0x5634125dd136
#10 0x5634125fc318
#11 0x5634125fca1f
#12 0x5634125fd6c6
#13 0x5634125ff822
#14 0x563412624ffb
#15 0x563412644d58
#16 0x56341263fe10
#17 0x7f27302b25aa start_thread
#18 0x7f2724ba5cbf clone
r8: 0000000000000001 r9: 000056341537790c r10: 0000563415377910 r11: 0000000000000001
r12: 0000000000000008 r13: 00007f26f19d4d90 r14: 00007f26f19d4fa0 r15: 0000000000000000
di: 0000000000000000 si: 00007f26f19d4d90 bp: 00007f26f19d4eb0 bx: 0000000000000008
dx: 0000000000000004 ax: 000033b1e30a99c0 cx: 0000000000000000 sp: 00007f26f19d4d30
ip: 0000563411acd5ba efl: 0000000000010206 cgf: 002b000000000033 erf: 0000000000000004
trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000010
[end of stack trace]
Calling _exit(1). Core file will not be generated.


#7

Not sure about that error in particular, but have you tried moving or deleting the Chromium config folder?

user@host:~$ mv .config/chromium/ .config/chromium_backup/

That will force creation of a new profile and configs that can resolve some issues, probably worth a try.


#8

this worked. Thanks dedxi!