Clonezilla encrypted recovery

I decided to install pureOS in replacement of debian for my server. I used clonezilla to copy all data to another disk. I cannot boot from it. What other things do I need to do to get this working? I get a decrypt screen but it says it’s waiting foa disk or somethibg for ages then I fall in a initramfs escape thing. I’m guessing I need to fix UUIDs but I feel very lost. Can anyone give me a comprehensive guide in fixing?
edit: starting to think I did the cloning incorrectly now. I have some timeshift backups on another disk just in case everything fails because this disk does currently have a few bad sectors now. Can someone guide me on moving everything? Please do not give only solution as just moving a few files in my /home because I have more than that on this system.
Some images can be found here:

Please clarify.

You got a server with an debian installation on its disk. You copied an image of the whole disk inclusive all partitions to a second disk. You overrode the first disk with a fresh installation of PureOS.

Is that correct?

From which disk do you want to boot?

what? Debian was old and I moved to pureOS before all of this. There is no disk with debian in this. I have pureOS encrypted LVM on a disk that is dying. How do I move it to a new disk with clonezilla? I cloned it over to the new disk. I get errors as described. I want to boot from the disk I cloned to. I throw away the original disk.
edit: To be clear, this was a disk to disk, NOT image creation.

Currently running a ddrescue booted from a flash drive. Finishes in predicted ~5 hours. If this doesn’t work either, I don’t know.

So I did that and still same error. I don’t know what to do.

Okay I haven’t got much aid here and other places on moving data and I tested in a vm for trisquel and it worked fine but pureOS can’t handle. I’m going to be manually moving over some files over to a new trisquel install and reconfigure a few programs because I’ve been on and off trying to fix this dumpster fire to no success. Bye pureOS :wave:

Moved over all data to my trisquel now and just need to configure 2 programs for maybe 2 hours total and wipe old disks before passing to a friend. Thanks anyways for having a libre distro even if it doesn’t work for me.

1 Like