Clonezilla USB stick for imaging entire OS

I’m very new to the Librem laptop and I’m having problems making a backup image before investing time to learn and modify the installation for my needs.

I usually use Clonezilla on an external USB drive to image my whole Linux drive, using dd. That way I can restore the complete OS when needed.

But it’s not working on my brand new Librem 14. Cryptic error messages pop up when I try to boot from the USB Clonezilla drive.

Anyone know a link to a tutorial about this?

Thanks a bunch!


Can you elaborate?

Regardless, I would use the PureOS live boot USB flash drive rather than a CloneZilla USB drive.

Thanks for your reply! :smiley:
My Librem 14 came with a ‘PureOS Live 10’ USB drive - so you say that does that have the capability to make an image of the installation? Suppose I’ll have to boot up with it.
Anyone have a link to a good resource to explain what the ‘PureOS Live 10’ USB drive is good for?

Regarding the Clonezilla failure:
First time I tried to boot from the Clonezilla USB drive, I got to a screen that made me choose if Clonezilla would run in one mode or another, what resolution, if from RAM or not, I think there were at least a dozen options (this screen does not appear when I clone my Ubuntu installations with the same USB drive). I chose some option and then got some error message which I did not look at carefully because I thought I’ll just try again and that I would choose a different option until I find which one works.
But I never managed to get back to that first screen when I tried again to boot from the Clonezilla USB drive.
Instead, I get the following text on an otherwise black screen (and then it hangs for a very long time, I assume forever but maybe I’m too impatient. I think I waited at least 5 minutes.)

Loading the new kernel:
kexec -1 /media/live/vmlinuz --initrd=/media/live/initrd.img --append="boot=live union=overlay username=user config components quiet noswap edd=on nomodeset enforcing=0 noeject locales= keyboard-layouts= ocs_live_run=ocs-live-general ocs_live_extra_param= ocs_live_batch=no vga=788 toram=live,syslinux,EFI,boot,.disk,utils ip= net.ifnames=0 splash i915.blacklist=yes nouveau.blacklist=yes vmwgfx.enable_fbdev=1 intel_iommu=igfx_off "
Starting the new kernel

After that, nothing happens.
I hope I did not put too many typo’s in while I was copying it from a photograph. :sweat_smile:

I would guess so. If you just want to use the dd command to image a drive, a PureOS live boot should work.

Live boot in general is good for

  • you need exclusive access to the boot drive (and hence can’t boot from the boot drive) - that would include imaging the boot drive, repartitioning, reencryption, file system repair if that were required, file repair if that were required
  • you locked yourself out e.g. forgotten login password
  • try-before-you-buy
  • some people also use it for getting a reproducible environment i.e. boot to known environment every time
1 Like

Thanks for the explanations!

It appears my Librem 14 has a random problem booting from USB, not really related to Clonezilla!

It happens with the PureOS Live 10 USB just the same.

I tried to boot from PureOs Live 10 disk a number of different ways but only once did it boot into the OS. I know it was actually the USB OS because it did not ask for the disk encryption nor the user password and started with the welcome screen for language selection.
But, following the exact same steps again results in an error message instead (see end of post for details)

At first I thought it might have to do with the Librem key in the other USB port, so I tried without it but got the same error message.

Then I swapped the PureOS Live 10 USB drive from right to left USB port, and that’s when it booted that one time.

Then I tried the Clonezilla USB drive in the left USB port, with and without Librem key, resulting in the same error message.

Then I tried again with the PureOS Live 10 USB in the left USB port - and now it is not working and showing the same error message.

Below is the error message ( I have not completely typed out the long ?hexadecimal? strings; they are always the same):

New value of PCR[4}: 69745da56385 etc etc etc 6d36

Scanning for USB storage devices…

mount: mounting /dev/sda on /media failed: No medium found

sh: o: unknown operand

!!! Something failed during USB boot

New value of PCR[4]: c7047 etc etc etc 995

!!! Starting recovery shell

~ # _

Any ideas anyone what is going wrong here?

You maybe need to update pureboot.

Maybe. Does Pureboot update itself once you connect the Librem 14 to the internet?

I was hoping to make a backup image which has not been connected to the internet.

And really, I think basic boot from USB function should not be dependent on the latest update, not cause random failure to boot.

It shouldn’t, but bugs get through some times. I think you can update it offline (and honestly this is a bit of a shot in the dark, I don’t have a librem).

I suspect not. That is, you have to go looking for an update and explicitly download it and then flash it.

Then if you can reproduce that, image the disk while you have the chance.

1 Like