Congrats on the progress!

I backed the phone back in 2018 (like many of you) and was excited about it back then, bought the devkit and wanted to develop for it and all that. Sadly the languages and libraries don’t line up with my job that much and so it was hard to justify working on it versus trying to keep up with all the other cloud related things I need for my job so all of this kind of fell to the side.

Well just a few weeks ago my Evergreen did arrive (for those still waiting, don’t give up just yet!) and wow has it come a long way! I was able to get it running on Mint Mobile here in the US without too much struggle and MMS and pictures even work now! The UI is much smoother and notifications show up on the lock screen like the big guys. It’s so close that I even tried to use it as my primary number over the weekend and almost made it! My wife laughed at how big it is, but said I sounded good on the call.

Sadly when the work week started I was making more important calls and the people on the other side couldn’t hear me. I tried to debug it, but nothing I did seemed to fix the problem. It’s slightly different than the forum topic about no call audio period. I can definitely hear them, they just couldn’t hear me. I checked the mute setting and the input device inside the settings/sound panel and that was showing the meter move as I talked so I thought that was encouraging, but somehow modem most not be using that mic.

The other deal breaking issue is that every once in a while the phone appears to just give up on the modem completely. This is kind of scary because then you can start missing calls and texts. I found a command something like mmcli -m any from another topic here and when it’s broken it says something like no modems found. I thought maybe restarting ModemManager might get it going again, but no luck.

I’m sure the developers are already aware of this and I look forward to learning more about how they are investigating it. In the meantime, I’m wondering if there would be a way to cron something that would check the status and if it does lose the modem maybe turn on the LED with a different color. Originally I was thinking of making it just restart to get it going again, but since it asks user for encrypt password during boot it wouldn’t get very far without user interaction. Haven’t looked into that either, but it would be kind of nice with that disabled. There is nothing sensitive on the device. Kind of overkill at the moment.

Anyway, I just really wanted to thank the Purism team for all the hard work and let them know that there are fans out there that are looking forward to getting more involved and watching this mature even more!


I also have problems with the modem. I haven’t noticed that it turns off, I can use it for wifi tethering all day for work, but if I switch the modem HKS off and then on again, the data connection doesn’t come up again. I’ll try to get time to report it in the issues, but at the moment there is so little time…

Maybe you should ask about this.

I can’t answer that but a different UI approach is to get the phone to talk to you. (I am using this as a warning when the battery gets low, via a cron job.) By “talk to you”, I just mean “play an audio file”. You can choose how “insistent” it is etc. etc.

Bash script posted by the developers on github to bring the modem back:


set -x
sudo rmmod xhci_plat_hcd xhci_hcd

echo 0 | sudo tee /sys/class/leds/wwan_en/brightness
sleep 2

sudo modprobe xhci_plat_hcd
sleep 5

echo 1 | sudo tee /sys/class/leds/wwan_en/brightness

This works for me but there is a another modem or kernel patch that is needed ill look for the link. It will still every say 30minutes loose the modem but typically come back. The script i have to run say every 2 days or so.

The modem issue affects me as well. Restarting the phone is the only way I’ve found to get it back. I’ve also noticed my VPN “Librem Tunnel” will randomly turn off.

I’ve had the same modem issue, and strangely enough the device will stop recognizing my SD card at the same time. Not really sure what triggers it though.

I’ve noticed this a couple of times over the months but may have missed is also. The script, shared by @Captain_Morgan is interesting but for convenience such would be nice if they could be gathered to one gui … like the one that’s already for VoLTE… (someone hint this to the right people if you know who they are). The “temporary workarounds app”.

Can you post the link / source where you found this script?

Thanks for the code! I knew this community would have some ideas. I just ran it and it seemed to get it going again. Let me know if you ever find the other patch.

I’m hoping I might be able to investigate the audio issue more this weekend.

and this still happens btw for me on:

Linux l5librem 5.18.0-1-librem5 #1 SMP PREEMPT Tue May 31 15:26:34 UTC 2022 aarch64 GNU/Linu