Connecting emails doesn't work, also pureOS Store is jank

When I tried to add my second email adress to Geary, I got “Unacceptable TLS certificate” from online accounts in the settings. Tried removing my account and see if the issue was related to that you could only have 1 account at any given time. Turns out that didn’t fix the issue, and now I literally can’t connect any email

also, is anyone else having the issue of the store being literally empty and taking forever to load in apps in any of the “explore” categories, and refuses to show any apps if you use the search bar?

Normal, in my experience. I guess because it has to fetch all packages afresh from Purism’s server. My Linux Mint repo on desktop takes a while to display, also.

Do you have “Show Incompatible Applications” enabled in the app preferences? (Many apps will be compatible anyway.)

Certificates are painful. There are too many points of failure and only vague error messages.

As a starting point, you will need to ensure that your system has the latest updates. That means that you will need to resolve the issue with PureOS Store if there is one. Personally I would go from the shell

sudo apt update
sudo apt upgrade

Coming back to the certificate … I assume you have reason to believe that the certificate is valid e.g. works when accessed from a different client computer.

I’m using Geary extensively but I must admit only with one account, so I don’t know about more than one account and/or removing accounts. The naming of the config files suggests that the intention is to support more than one account. The one account that I am using exclusively uses TLS - so TLS definitely can work with Geary.

I don’t know how technical you are but if you want to eyeball your Geary config file(s):

I can literally not run “sudo apt update” now, because “certificate verification failed”. I have the time set to be automatically updated to be correct, so I have no clue what the reason for this is.

Also, for the store, I have never had any issues with it when I used pureOS on my laptop, hence why I’m bringing it up here. Even with “show incompatible apps” enabled, I still get empty pages when I click any of the explore categories.

So assuming that it actually is correct, you may be getting bitten by an expired (intermediate) certificate that prevents you accessing the repo to get updated certificates.

If that is the case, a temporary workaround procedure is here: Librem 5 will not update with wifi

Thank you for the potential solution, sadly that wasn’t the issue.
The issue was that I assumed selecting automatic time would make date and time be set correctly. The date was set to 21 march of this year. I managed to get sudo apt update to work now.
This also made it so that I don’t get the certificate error any longer.

I still find it strange though that I can no longer select whether to have automatic date and time anymore.

You should be able to revert to automatic once you have the date/time set correctly. Requires internet connection, of course.

nope, just checked and despite it being set correctly, and me having wi-fi access, I cannot see the toggle option in settings anymore.

Weird. It’s there for me: