Consumer Cellular on my librem5

I have had Consumer Cellular on my librem5 working for a few months, but my sim card failed so I got a new one at target… since using this new sim card I get full signal cut can’t make a receive a call via the carrier… even data / browsing the web is fine.
in looking at dmesg from a terminal I see

[ 612.569244] wlan0: authenticate with xx:xx:xx:xx:xx:xx (different mac obviously)
[ 612.569304] wlan0: bad VHT capabilities, disabling VHT
[ 612.569864] wlan0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[ 612.576920] wlan0: authenticated
[ 612.580275] wlan0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[ 612.584254] wlan0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x1431 status=0 aid=7)
[ 612.585412] wlan0: associated
but I am uncertain if that is why…

Any suggestions on what I might try to gett full functionality again?

wlan0 is WiFi, isn’t it?

whoops yeah thought I read wwan0

ok so the wlan0 is not related… but I do on ocassion get a message that flashes on the screen Error:org.freedesktop.ModmManager1.Error.Core.WrongState: not register modem: modem is connected

But you would need to disable the WiFi in order to make sure that data is actually working via the cellular modem. Easiest would be to use the HKS to kill the WiFi.

which I did… also even sms messages went out… but calls are still not working

VoLTE issue? Depends on the country.

1 Like

Just a guess but I’ve seen this elsewhere in the forums…

Do you have another (non-L5) phone that you can insert the SIM in, make/receive a call or text or two, then stick it back in your L5?
Pretty sure I’ve seen something like this suggested to “activate” the SIM with the carrier.

1 Like

Also, I think I may have had something like that and hazily recall that my date/time was off (had removed the battery). It also prevented internet access via mobile data. A bit of a stretch, I know.

yes I activated this new sim on a old iphone 7 plus and it works fine there, I also contacted the Consumer Cellular and had them “update the IMEI” in their system which made no difference…

right wrong time would mean all certificate fail etc… but that is deafinately not the case here… internet / data fine with wifi off etc… but calls failing to go out or come in

After a quick search, it seems this kind of problem is troubleshooted a lot by checking with mmcli the modem state info and info, which the error message hints at. A faulty or wrongly set up SIM is one possibility too but less likely IMHO.

Well that error only popped up once or twice when trying to edit carrier settings, so it might not mean anything is wrong, but mmcli is interesting… not sure what to look for there… nothing seems wrong that I can tell… even when I am in the place with the worst signal I get it shows 55% and dataworks, but voice calls still fail

Status | lock: sim-pin2
| unlock retries: sim-pin (3), sim-puk (10), sim-pin2 (3), sim-puk2 (10)
| state: connected
| power state: on
| access tech: lte
| signal quality: 55% (cached)

Maybe this means something… I tried to query call waiting and got an error
mmcli --modem=/org/freedesktop/ModemManager1/Modem/0 --voice-query-call-waiting
error: couldn’t query call waiting network service status: ‘GDBus.Error:org.freedesktop.libqmi.Error.Protocol.SupsFailureCase: Couldn’t query call waiting: QMI protocol error (92): ‘SupsFailureCase’’

I also noted when looking in dmesg that wwan0 changed to wwx2202f6e25b11 when it got an ip address … but nothing is pointing me to how to tell when it can’t make calls (yet previous sim did before it failed)

[ 41.617400] qmi_wwan 1-1.2:1.4 wwan0: register ‘qmi_wwan’ at, WWAN/QMI device, xx:xx:xx:xx:xx:xx
[ 43.003333] qmi_wwan 1-1.2:1.4 wwx2202f6e25b11: renamed from wwan0

Don’t suppose it’s something simple like your APN settings are messed up?

I don’t think so… I got those from Consumer Cellular directly even after I used what worked before… I even went as far as to reflash the phone in case there was a corrupt setting… I think the sim might be somehow different config than the previous sim which is not compatible for the phone function… all data and sms work though… kind of a fail … I ordered a libre-awesim this morning… hopefully I get good results / coverage

Your problem seems very similar to mine. Everything works but phone calls.

What is the behavior on the screen when you try to make a call? Mine instantly just says “Call Ended” and in the log I see QMI Error of “NoNetworkFound”. Even though all the modem settings were adjusted to supposedly enable the VoLTE.

I’ll let you know if I make any progress, but I’m currently stuck trying to figure out the debug output from ModemManager. T-Mobile says my IMEI has full capabilities and the SIM worked great in another phone too.

I also debated giving up and switching to awesim, but with the recent outage, the much higher price than what I’m paying now and the changing behavior of the company, there is no way I can justify it.