CPU fan stuck at high speed sometimes

Also experiencing this on a librem 13 v4, CPU stuck at 400Mhz, fans running at full speed.

the fix is to keep opening and closing the laptop until it stops.

1 Like

can anyone confirm if this is a firmware issue or is it something on the higher ring ?

Same here with a Librem 15v3 which have Coreboot from May this year. I guess it’s the latest.

It has now officially been a full year since @mladen’s response that the coreboot team was looking into this. I wonder if there has been any progress? I do appreciate all the excitement that the phone has been getting, but sometimes I worry that there may not be sufficient resources to address some of the really frustrating issues with existing hardware that customers have been working around for a long time.


This bug is so ridiculous!

Any time i change the power state of my laptop it drops the CPU to 400Mhz and spins the fans up!

I just plugged my charger in and CPU throttled to 400Mhz??

Any updates on this?

If this is true, you might want to get in touch with them. One reason why it is so hard to fix this is that is occurs very rarely for most users, which also means one can hardly know if a change actually fixed it.

1 Like

Did you try to upgrade Coreboot already?
We are still unsure where this problem comes from - if it is the EC or some weird side effect. So far we have indeed (and sadly) not been able to pinpoint the root cause :frowning:


I have not updated my coreboot version since receiving the librem 13v4 a few weeks ago, after 6 months waiting for a replacement.

Hi all,

Maybe these steps will help reproduce.

I use my laptop plugged in via HDMI with a USB-C hub (keyboard/mouse/headset).

If i plug in my charger the CPU drops to 400MHz, i then have to use a gnome plugin called “CPU-Z” to tell the CPU governor to use 100% of the CPU, everything is fine then.

If i then let the laptop go to sleep for around 15 minutes (eating lunch) and return, when i wake the laptop, the fan then spins at 100% and the CPU is then throttled to 400MHz, however this time the “CPU-Z” plugin can not recover this, so i have to unplug the power adapter & HDMI, shut the laptop lid and let it go into hibernation.

When i then open the laptop, the fan is throttled down again and “CPU-Z” can then tell the governor to use 100% of the CPU again.

I hope this information can help.


1 Like

I can reproduce these steps without fail on a librem 13 v4 every time

Possibly related with: https://github.com/erpalma/throttled

Surprisingly, after I wrote my comment here I didn’t get that error again. But I also played around with some distros and ended up with Manjaro, using the 5.2 kernel. I’m not sure if this was the solution or maybe that I installed TLP and did some settings for the CPU_HWP. Either way, no weired fan actions and no freezes anymore!

1 Like

So, if it is interesting for anyone. I got some trouble with Manjaro and switched back to Linux Mint. I also updated Coreboot to 4.11 - After a while I got the weired fan back and it seems again that a kernel update (from 5.0 to 5.3) solved this issue for me. Because I did the same TLP CPU_HWP edit (to get sure that this won’t happen) but afterwards the fan got still mad. With the following kernel update everything is fine, till now.

Ok, kernel update didn’t help. Occasionally the fan is stlll getting weird after sleep…

@ollrich can you still produce this with some consistency? If so, I have a test build I’d like you to try, so shoot me a PM

@MrChromebox It still happens occasionally but not really with consistency. Every 2 to 5 wake ups from suspend, sometimes it needs more to trigger that problem.
I’m using a small workaround and put my machine to suspend via systemctl suspend not by closing the lid. That is helping a little bit (maybe after 12 to 15 wake ups the error than happens) but doesn’t solved it.

Is this a test build I could use on my daily driver? or could this be problematic?

can you do me a favor and install the lm-sensors package, and run watch -n 1 sensors to get an updated temp output, and then reproduce the issue. I’m curious if any of the temp readings are incorrect/invalid when the issue occurs. I’ve suspended 100+ times over the past few days and unable to reproduce it here

1 Like

@MrChromebox it took a while but I got the error just now. Seems like nothing happend to the temp output


@MrChromebox is there anything else I can help with?

I was wondering if the CPU temp was being reported incorrectly / too high in cases where the fan speed is stuck at max, but that appears to not be the case. Need to do some more digging it seems

May it be helpful:
Had it a lot with my L13 two years ago, but it got better with PureOS updates. Still the same coreboot etc. it was shipped with.
Now I’d say I get it every twentieth time or less.