CPU fan stuck at high speed sometimes

Hi all,

Maybe these steps will help reproduce.

I use my laptop plugged in via HDMI with a USB-C hub (keyboard/mouse/headset).

If i plug in my charger the CPU drops to 400MHz, i then have to use a gnome plugin called “CPU-Z” to tell the CPU governor to use 100% of the CPU, everything is fine then.

If i then let the laptop go to sleep for around 15 minutes (eating lunch) and return, when i wake the laptop, the fan then spins at 100% and the CPU is then throttled to 400MHz, however this time the “CPU-Z” plugin can not recover this, so i have to unplug the power adapter & HDMI, shut the laptop lid and let it go into hibernation.

When i then open the laptop, the fan is throttled down again and “CPU-Z” can then tell the governor to use 100% of the CPU again.

I hope this information can help.


1 Like

I can reproduce these steps without fail on a librem 13 v4 every time

Possibly related with: https://github.com/erpalma/throttled

Surprisingly, after I wrote my comment here I didn’t get that error again. But I also played around with some distros and ended up with Manjaro, using the 5.2 kernel. I’m not sure if this was the solution or maybe that I installed TLP and did some settings for the CPU_HWP. Either way, no weired fan actions and no freezes anymore!

1 Like

So, if it is interesting for anyone. I got some trouble with Manjaro and switched back to Linux Mint. I also updated Coreboot to 4.11 - After a while I got the weired fan back and it seems again that a kernel update (from 5.0 to 5.3) solved this issue for me. Because I did the same TLP CPU_HWP edit (to get sure that this won’t happen) but afterwards the fan got still mad. With the following kernel update everything is fine, till now.

Ok, kernel update didn’t help. Occasionally the fan is stlll getting weird after sleep…

@ollrich can you still produce this with some consistency? If so, I have a test build I’d like you to try, so shoot me a PM

@MrChromebox It still happens occasionally but not really with consistency. Every 2 to 5 wake ups from suspend, sometimes it needs more to trigger that problem.
I’m using a small workaround and put my machine to suspend via systemctl suspend not by closing the lid. That is helping a little bit (maybe after 12 to 15 wake ups the error than happens) but doesn’t solved it.

Is this a test build I could use on my daily driver? or could this be problematic?

can you do me a favor and install the lm-sensors package, and run watch -n 1 sensors to get an updated temp output, and then reproduce the issue. I’m curious if any of the temp readings are incorrect/invalid when the issue occurs. I’ve suspended 100+ times over the past few days and unable to reproduce it here

1 Like

@MrChromebox it took a while but I got the error just now. Seems like nothing happend to the temp output


@MrChromebox is there anything else I can help with?

I was wondering if the CPU temp was being reported incorrectly / too high in cases where the fan speed is stuck at max, but that appears to not be the case. Need to do some more digging it seems

May it be helpful:
Had it a lot with my L13 two years ago, but it got better with PureOS updates. Still the same coreboot etc. it was shipped with.
Now I’d say I get it every twentieth time or less.

I was getting it quite often as well, but after several coreboot updates I’ve had it happen only once in the last ~8 months.

Off topic: The fan curved used on the Librems is fantastic! Nearly silent for most of the things I’m doing. Only when firing up a VM or compiling does the fan ever kick on.

In the last couple of weeks I noticed that my Librem got very slow after waking up from suspend without this weired fan. Even simple text editing isn’t possible. I do have to do a complete shutdown and start it again.

Hi…first off my cpu cooler is a Scythe Katana 3 and the motherboard is a Asus H97-plus. The fan has 4-pins and worked flawlessly (or almost) until now. Yesterday, after booting the PC (it was in stand-by, but it doesn’t matter I think), the fan, which usually starts at really low speed, was at 100% speed (2800rpm). The fan stayed at such speed constantly since then, with the exception of 1-2 seconds every now and then when it goes back to a normal speed.

printed circuit boards

I notice that this issue appears when device configuration was changed. For example, if you connected to USB hub and plug out some devices while laptop sleeping.

1 Like

That is a very helpful clue and I would think it would help to nail down any remaining cases of this. I haven’t had the issue on my L13v2 for a while now, and I think this is probably why.

Lol, it 100% repeatable. I have soundcard with USB hub functionality (MAudio MTrack HUB). It have 2 operation modes:

  1. When soundcard (which is USB hub too) connected to external power supply, it provides soundcard and USB hub functionality.
  2. When soundcard connected without external power supply, it provides only soundcard functionality.

It mean that if I turn off soundcard power supply, all devices become disconnected from hub, except soundcard device. For laptop, this soundcard represented as USB hub with one connected device. And if i turn off power supply for my soundcard (the sound card is connected to the same 220V splitter as the speakers) when my laptop is sleeping, this bug appears.

I think that everyone can repeat this steps, using generic USB hub and disconnect some devices from hub, while laptop is sleeping. Someone can try this?

I’ve suspended 100+ times over the past few days and unable to reproduce it here

Are you using Pureboot or Coreboot? Because if you using Pureboot and me using Coreboot, maybe there is a chance to nail it a bit more down?

coreboot, 4.11-Purism-1