CPU fan stuck at high speed sometimes

I was getting it quite often as well, but after several coreboot updates I’ve had it happen only once in the last ~8 months.

Off topic: The fan curved used on the Librems is fantastic! Nearly silent for most of the things I’m doing. Only when firing up a VM or compiling does the fan ever kick on.

In the last couple of weeks I noticed that my Librem got very slow after waking up from suspend without this weired fan. Even simple text editing isn’t possible. I do have to do a complete shutdown and start it again.

Hi…first off my cpu cooler is a Scythe Katana 3 and the motherboard is a Asus H97-plus. The fan has 4-pins and worked flawlessly (or almost) until now. Yesterday, after booting the PC (it was in stand-by, but it doesn’t matter I think), the fan, which usually starts at really low speed, was at 100% speed (2800rpm). The fan stayed at such speed constantly since then, with the exception of 1-2 seconds every now and then when it goes back to a normal speed.

printed circuit boards

I notice that this issue appears when device configuration was changed. For example, if you connected to USB hub and plug out some devices while laptop sleeping.

1 Like

That is a very helpful clue and I would think it would help to nail down any remaining cases of this. I haven’t had the issue on my L13v2 for a while now, and I think this is probably why.

Lol, it 100% repeatable. I have soundcard with USB hub functionality (MAudio MTrack HUB). It have 2 operation modes:

  1. When soundcard (which is USB hub too) connected to external power supply, it provides soundcard and USB hub functionality.
  2. When soundcard connected without external power supply, it provides only soundcard functionality.

It mean that if I turn off soundcard power supply, all devices become disconnected from hub, except soundcard device. For laptop, this soundcard represented as USB hub with one connected device. And if i turn off power supply for my soundcard (the sound card is connected to the same 220V splitter as the speakers) when my laptop is sleeping, this bug appears.

I think that everyone can repeat this steps, using generic USB hub and disconnect some devices from hub, while laptop is sleeping. Someone can try this?

I’ve suspended 100+ times over the past few days and unable to reproduce it here

Are you using Pureboot or Coreboot? Because if you using Pureboot and me using Coreboot, maybe there is a chance to nail it a bit more down?

coreboot, 4.11-Purism-1

Yeah, would be too easy…

I notice that this issue appears when device configuration was changed.

Agreed. This most recent time I ran into this issue, I suspended the laptop with an external mouse plugged in, unplugged the mouse, and then woke up the computer. On wake up, the CPU speed was stuck at the lowest speed (400 MHz) and fan was going full bore.

Another suspend/wake cycle without changing anything brought back normal behavior.

Just stumbled over this topic again … and realized, that i didn’t have the fan revving up anymore since weeks.
By accident (my fault) i had my PureOS only overwritten by Debian. Being lazy (and not willing to open up another time-consuming task on a long list of work to do) i kept it as it is. Might be, switching to Debian did the job to calm down the fan.
Unfortunately i’m not sure. But wanted to mention it anyway.

I’m running Debian (sid), so it seems like you’ve just been lucky since switching :slight_smile:

This is a bios firmware thing. If you haven’t already i’d make sure you’ve updated it using the script present here on these forums. However, I believe the issue highlighted above has not yet been corrected. (That is if you unplug a device from a USB port while the device is in standby, and then resume, you will trigger the fan condition.)

That’s exactly what happened for me recently. Librem 13 v3. But I didn’t know how to fix it except to reboot, so thanks for that. Next time, I’ll just close the lid, sing Happy Birthday twice and open the lid.

Any news on that issue?

And besides, just found this: Librem 15v3 reveiw (1year) - This issue is around for 7 years and the best solution is still to close the lid and reopen it?

Never had this issue again, since upgrading coreboot to the newest release.

1 Like

Now that you mention that: I haven’t had it in quite a while either. Tend to keep my pureboot up to date. @ollrich: You might be the perfect person to test if that actually did it or if my hearing is failing :wink:
Btw: Sometimes the fan still is on, but then usually because the indexer is running in the background, so there’s a reason for the fan.

I’m on a 13v2 but I too can’t remember the last time this happened to me. I would absolutely run the coreboot update script. It is distro agnostic.

1 Like

That’s good news, but the coreboot update is still beta, which gives me pause. Why hasn’t Purism moved this to production?

I don’t know, I just run the script.