Crimson Bricked on Custom Hardware

I was trying some stuff, and upgraded PureOS Byzantium to PureOS Crimson by looking at the tutorial from Amber to Byzantium on the PureOS download front page and typing Crimson instead of Byzantium.

I did this on nonstandard hardware, not a Librem device from Purism.

Ever since the update, the lightdm installation I was using stopped launching. So I tried installing gdm3 again (I had removed it). Didn’t fix the issue. After boot, I am stuck on fsckd-cancel-msg:Press Ctrl+C to cancel all filesystem checks in progress.

But Ctrl+C does nothing. I am able to use CTRL+ALT+F2, or ssh, to open a console.

I tried changing apt sources back to byzantium and running sudo apt reinstall '~i' which the internet suggested might do a full reinstall. But, still stuck on the same issue.

Is clean installing Byzantium the only option or is this recoverable because I can still get to a console? The clean Byzantium install was working fine, but I only installed within the last week and didn’t setup backups yet.

(Byzantium was running fine but the reason for investigating Crimson is that I was trying to investigate my options for better nvidia card performance. llvmpipe was getting used for 3D which is software rendering, and I wondered if there is a way to get nouveau to do hardware rendering, maybe on a newer version)


It may be recoverable, but I prefer unbrickable clean installations. If you want the Crimson ISO, you can get it from here:

Index of /crimson/gnome/2023-11-28/


Before doing that, since you do still have shell access, are there any files that you would like to rescue first?

Otherwise, I would suggest a clean reinstall from scratch of byzantium is the best approach. It is always possible that you can work out what went wrong and cobble a fix together but …

However before you do that, you might want to try a clean install from scratch of crimson. I say this because you don’t know whether the problem is a) crimson just won’t work out-of-the-box on your hardware or b) crimson is not yet ready to be installed by upgrade from byzantium.

1 Like

Probably not, but I saved a few just in case.

I tried Crimson live boot from flash drive. It doesn’t get as far as the install that I tried to upgrade – instead sits at a flashing underscore. The Ctrl+Alt+F3 style recovery consoles were clickable and it would momentarily show a login prompt, but then remove it before I could humanly actually enter any credentials.

Seems I will be on Byzantium, then.

Edit: Took me a few to redownload a copy of Byzantium live ISO because I didn’t have one sitting around, but it’s night and day compared to the Crimson live iso. Happily opens a graphical desktop immediately upon booting.