Cryptsetup fails during boot, halting system

When I power on the system, I get the following messages:
firmware: failed to load i915/skl_dmc_ver1_27
WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Volume group crypt not found.
Cannot process volume group crypt
cryptsetup (sda5_crypt): cryptsetup failed, bad password, or options?
Please unlock disk sda5_crypt:

whereupon I enter the encryption password and everything proceeds normally. At other times, I simply get a blank progress bar that remains until I hit the Purism key and then I get the graphic disk encryption unlock request and all proceeds normally.

I tried the “broken system upgrade” fix, but it didn’t work. I wasn’t doing anything special at the time, but I had recently installed kMyMoney as a sub for GnuCash and was working through the online banking setup. Obviously disk encryption is fine, but the boot process is corrupted.


I’ve got the same problem, but I haven’t installed anything lately, just the regular updates. Could it be that cryptsetup itself is being deprecated?

I got the same problem.

Happened to me as well.
After apt full-uprade with Kernel Version 4.16, my Librem stalled on decryption at each boot.
But ignoring the halted progress bar and just entering the Password blindly, without the input field appearing, let the Librem boot.
Booting on Kernel 4.15 also solved the issue.

I am also having this issue.

I had the same issue after a sudo apt upgrade to the latest packages.

After an earlier upgrade I always had to type in my password twice at boot because of this issue. After fiddling with cryptsetup and trying to fix things I just reinstalled pureos and did not update anything.
So far I have no further issues except for many halted updates.

I would be happy if someone knows how to properly fix this.

Also related:
Decrypt prompt disappeared after update
New Librem 13v3 Won’t boot to disk login

This appears to be the root cause, both here and at the Debian forums. The best workaround is to simply enter your encryption password, hit Enter a couple of times and then the Super key. If you misenter the password, you should get the password box and a normal error message.

This has now been fixed… Please see

During a similar upgrade, I recall seeing a message that the cryptsetup settings were set up in the wrong directory, and that future upgrades would no longer support this (now) erroneous directory setup. So while simply typing your password without the prompt works for now, subsequent upgrades might be a problem. Is there a way to review the log of the update? Perhaps all you need to do is upgrade the location of the relevant file(s)…

The failure of the UI password box to appear has been fixed in the latest upgrade. However, as near as I can tell from a flash-by text message, the “missing firmware” error is still present, but it doesn’t appear to hamper booting, so I am just ignoring it.

Mine is still not working; I have this problem too, even with “the latest upgrades.”

I hit alt + f2 + super and get additional error messages. When trying to type the password as you say it seems to be telling me “no key available with this passphrase” and i hit enter, and just try entering my password many times to no avail.
The only way I can boot my laptop right now is by booting up, getting cryptfail, then hard-powering down and back on so I get the menu for advanced options to boot in version 4.15.

Please help!! Seems a bit dampening to drop $1800 on a laptop only to update it and have it no longer boot properly.

Can ypu boot into older kernel? Press ESC as soon as Purism logo disappears, select advanced and then select kernel 4.16 too boot.