New Librem 13v3 Won’t boot to disk login


#1

Hoping someone can help.
Just got my brand new Librem 13v3 as a warranty replacement for my Librem that couldn’t be repaired.
Started from scratch.
First thing I did after getting set up was update and upgrade with
sudo apt update && sudo apt full-upgrade
Went fine. Shut down and tried to reboot but it won’t boot to the screen where you unlock an encrypted disk. It just hangs at an empty progress bar.
After trying every key combo, I finally stumbled on Ctrl, then Alt, which after several tries gets me to the disk encryption password entry and it will boot fine.
I found the thread and ticket about login issues and performed the Ctrl+Alt+F2 followed by
sudo dpkg —configure -a: followed by another round of command line updating and upgrading.
Didn’t fix it.
No matter what I try, every startup or reboot hangs here
Appreciate any help

IMG_0795.jpg


Updating Coreboot when running another distro?
Cryptsetup fails during boot, halting system
#2

Hi @phyzog,

There is nothing very exotic in what you did, this is very surprising.

Did you try to boot a liveusb?
Did you try a reinstall of PureOS?


#3

Try just typing your decrypt password at the point you see that bar. You should see the prompt after a few keystrokes and things will proceed normally.

I opened a ticket on this in the PureOS tracker: https://tracker.pureos.net/T422


#4

I have the same problem. I simply type in the encryption password, hit Enter a few times and then press the Purism key and it successfully decrypts. Prior to this point I got error messages about missing firmware, which were likely bogus, and caused my post on the issue to be ignored.


#5

Thanks for the detailed report with solution @Wayne :slight_smile:


#6

I seem to have the same problem and I have a Librem 13v2, I think (how would I find out?). Did a software updated yesterday and that’s when these problems started. I found that I can use Ctrl Alt and the function keys (F3?) to switch to the console where I can see the prompt. There, I can also provide the passphrase and booting will resume. If I just hit some other Ctrl Alt function keys eventually the decryption prompt will also appear with a GUI, so I agree, a workaround is possible but this is super annoying, of course.


#7

Thank you, I tried your workaround and I got the same results.
Cheers


#8

I had the exact same issue occur last night after applying the most recent Pure OS upgrade.

Managed to get the OS running by hitting escape on boot > advanced options then choosing the 4.15.0-3-AMD64 option in place of the default 4.16.0-1. But the computer will no longer the OS automatically with the power button, and I’m not sure if we can roll back the changes.

It is DEFINITELY related to the Pure OS update.


#9

kensanata, you may not need to do all those gyrations. Just start typing your password. At least for me, the keystrokes get buffered, the prompt suddenly appears, I can complete the entry, and everything is normal. Sorry if I was unclear in my post.

I only received my Librem a month ago, so this may have changed over time: the model and version are on the bottom if one turns the system over.


#10

You can also move your mouse to get the password prompt to appear - also got this on my 15rev2.

It wants a level of entropy before letting you proceed. Some discussion happening about it over on the debian bug tracker here: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=897572


Encryption password skipped at boot time after update
#11

Thanks, Kris. I added this link to the Tracker Task describing this bug.


#12

This issue appears to be fixed with plymouth-themes 0.9.3-3pureos1 and fontconfig 2.13.0-5. I just updated and the problem no longer occurs on my system. (Thanks mak, chris.lamb, et al.)