Debian


#1

I installed Debian Jessie alongside PureOS on my Librem 13, because I’m very picky about building up from a base-install among other things.
I did the install with only the “free” repo (and later added contrib to install torbrowser-launcher).
I used Jessie (stable) with the latest backported kernel 4.2.6 in jessie-backports.

Here are a few things that I noticed / am tweaking:
The kernel warns about possible missing firmware for the Realtek ethernet adapter - you should ignore this, ethernet works perfectly without needing any non-free firmware.
Touchpad / trackpad - I’m not having much luck with multitouch in my Debian install, but it works in PureOS (which looks to be based off Stretch [testing]). I assume that I’m missing a package for this, or need to install a newer version of one and haven’t done much research. I have xserver-xorg-xinput-multitouch. I’m also using enlightenment 17, which is rather finicky.


#2

You may want to try my dkms psmouse module at https://github.com/kylerankin/psmouse-byd-dkms. I’ve basically just taken the patches that the Purism team has done against the Linux kernel and converted it into a DKMS-compatible package. I’ve only tested it against the stretch kernel but if you are using the backported jessie kernel you should be able to compile the module and load it.


#3

Kyle - thanks for the code and your help on IRC a couple weeks ago. This worked pretty well for me although I’ve had some occasional freezes of the touchpad. I’m going to try the version with your latest commits and see if that clears up.


#4

We are currently in progress to mainline our latest work on touchpad so everyone gets it out-of-the-box.


#5
"We are currently in progress to mainline our latest work on touchpad so everyone gets it out-of-the-box."

Nice ! Yes please :slight_smile: couldn’t wait for two-fingers scroll to work, edge-scrolling somehow makes me edgy :smiley:

Currently using bluetooth mouse to compensate.

Thanks everyone !

cheers, HS


#6

Jason, did you have any issues with the wifi with a fresh Debian install? Ethernet connects fine, but DHCP isn’t working over wireless. It’s had me pulling my hair out all morning.


#7

Hm, I have Debian and no problems here. What Debian do you use (maybe it needs newer driver) also notice that because it uses free driver it doesn’t have as good signal reception as it would with ac driver :-/ so try being closer to your router when you’re trying this (and have a higher timeout).


#8

I was literally right on top of the router. My problem ended up being NetworkManager, once I disabled it and rebooted (with a nice wpa_supplicant.conf and etc), it worked totally fine.

Now to figure out how to make the camera work. I haven’t had linux on a laptop for about a decade (so haven’t had to deal with webcams before), and I don’t even know where to start with this one…


#9

It’s Debian 8 with KDE, but I’m playing around with i3wm and probably getting rid of the KDE part.

Where would I set the wifi timeout? In /etc/networking/interfaces or somewhere else?


#10

Is it possible to “dist-upgrade” to Debian…? (i.e. put the Debian repos in sources.list and treat it like a “normal” Debian upgrade)