Default ip configuration on the default pureos image


#1

The default image of pureos that comes with the dev board have a default static ip configured (also with a default route). If you have a DHCP, to have access to your network, you have to, at least, remove (or change) the default route with:
ip route del default via 192.168.42.200 dev eth0

If you want to disable it permanently, you have to edit the file /etc/network/interfaces and comment out the lines after “auto eth0”. You can also change the static ip configuration to suits your needs.


#2

After upgrading to the latest image everythings works out of the box. So my previous post is only good if you did not upgraded yet and want to use network.

Here is the steps for the upgrade:
https://developer.puri.sm/Librem5/Development_Environment/Boards/imx8.html


#3

version: Linux pureos-test 4.18.11-g510718c9

The version I received used DHCP to assign itself an ip number. Just an FYI in case you can’t connect to the device check your DHCP lease table, it might contain a lease :slight_smile:


#4

The NetworkManager keep changing the MAC address at every reboot so if your devkit is configure with DHCP, you will receive a new IP at every reboot. It is great for your privacy when you connect on public wi-fi on the road but for development, always on the “safe” home network, it is kinda annoying. So here is how to disable this behaviour:

  • Create the file: /etc/NetworkManager/conf.d/100-disable-wifi-mac-randomization.conf
  • Put this in it:

[connection]
wifi.mac-address-randomization=1

[device]
wifi.scan-rand-mac-address=no

  • Save the file then reboot, the MAC should not change from now on