Desktop Environment fails to launch after install


#1

Greetings everyone!

I just got through installing PureOS on my system via the live installer iso and I’ve run into a problem. While I was able to get a GUI on the installer, my fresh install refuses to launch GNOME or any sort of login prompt. I can scroll to tty2-4 and log in through the console, but tty1 is just a black screen with a blinking “_” in the upper left-hand corner.

The system I installed the OS on is an AMD computer with a newer Radeon graphics card, I think the RX 560. While booting I do briefly see an error message complaining about Radeon firmware missing, however, I don’t understand why it won’t show me a GUI now when it had no problem doing so on the live ISO. Clearly, PureOS can run on my system if I was able to use the live ISO with no issues, right?

I guess I’m at a loss. Any help with troubleshooting this issue would be greatly appreciated!


#2

The “Pure” in PureOS refers, at least in part, to the fact that it is all FLOSS software. With your graphics card requiring proprietary drivers, they aren’t there. I would think that could cause problems with using X or Wayland… using that logic, I would think that you would have issues with the live ISO, too.

Since you didn’t, the only things I could take a jab at are:

Attempt to manually launch GDM:

Attempt to reinstall the desktop:

Attempt to fix the missing firmware:


#3

Hey, thanks for the reply. Yea, I knew I was going to be installing an OS that is free of proprietary software. I was under the impression though that ATI cards could function using the mesa software stack. Also, seeing how the live install displayed the desktop fine, I thought I was in the clear. I’ve tried all three of your suggestions with, unfortunately, none of them working for me. I’m still left with the same screen upon boot.

I wish there was a way to figure out what drivers are being utilized to display the GUI on that live install, maybe then I could replicate it on the actual system.


#4

Glad to try to help!

You might be able to…

If you boot into the live image again, and then run this in the terminal:

lshw -c video

It should tell you what driver is currently in use (see the configuration line):


#5

Thank you again for the suggestion! Actually, I was able to get my system working. Not exactly the way I wanted, but it’ll be fine. I couldn’t help but think that maybe it had something to do with the radeon firmware, so I found an old Nvidia card and decided to install that and see if it’s friendlier with free software. Turns out, it was. I did a fresh install and everything seems to be working as it should. Maybe I never solved the mystery I was experiencing, but I was able to get a working system and that’s what matters.

I appreciate your help!


#6

Can you tell us which driver is in use now that it is working? e.g. use above lshw command

Maybe the nouveau driver?


#7

Can you tell us which driver is in use now that it is working? e.g. use above lshw command

Maybe the nouveau driver?

It is indeed the nouveau driver. I don’t quite understand why NVIDIA has better support for non-proprietary software than ATI does considering how poor nouveau performs compared to Radeon, but alas, such seems to be the case. At least I don’t plan on doing anything graphically intensive on this machine.


#8

HA ! well Linus Torvalds gave nVidia the middle finger some years ago on video ! and it’s better support for proprietary drivers not OSS. AMD radeon is by far the best OSS driver for 8-bit color out there (gaming performance is sometimes better on linux than on other OS)