Did I just brick my Librem?


#1

I was trying to install Qubes 4 on my brand-new Librem 13v2 and it didn’t quite work. That’s fine, I was just giving it a try. However, it seems I got myself into a pickle now. My Librem doesn’t seem to boot anymore.

When I press the power button, the “on” LED turns on, but there is nothing on screen (not even the Purism logo screen that lets you press Esc for boot order), and a few seconds later, the “on” LED simply turns off. I tried pressing Esc just in case that might bring me to the boot order screen, but no, it doesn’t change anything: nothing on screen and the “on” LED still turns off soon after. So I can’t even try and restore PureOS from USB.

How can I diagnose this better, and/or how can I fix it?


#2

that sounds like a question for support. did you write them an email already?


#3

Can you still boot a live usb?

If yes, you may try to reinstall PureOS completely. If not, try emailing the support :slight_smile:


#4

@rmf, try this: remove the back cover and disconnect the battery connector, leave it for an hour or two and then try starting your laptop with AC plugged-in.


#5

Once you do get your Librem 13v2 working again, we should be finished releasing our new coreboot image with IOMMU support so Qubes 4 should install and work well:
https://puri.sm/posts/qubes4-fully-working-on-librem-laptops/
We are finishing up testing and cleaning up the code a bit, and then we will publish it so you can update.


#6

Just unplugging the AC overnight seems to have fixed it :expressionless: I’m not sure what happened there.


#7

Any idea when this will be ready? For now I managed to get Qubes running with the sys-net VM set to PV mode.


#8

@mladen I have the same issue as OP. I tried to disconnect the battery connector but couldn’t find a way to separate it. How can I do this? Is there any additional tools needed to do this? Thanks.