Disable Luks Auto Decrypt of External HD


#1

Hey everyone. I have an encrypted thumb drive. My system used to prompt me for a password every time I tried to mount it. The last couple of times I plugged it in, it auto decrypted and mounted. I figure I must have accidentally hit “remember password” one time while decrypting it. However, i can’t figure out how to get my system to forget that password. It doesn’t seem to be in my password manager or anywhere obvious that I can see. I’ve been searching the web, but everything I can find is how to enable auto mounting, not disable it. And anyway, the things I found don’t seem to apply in PureOS.

Thoughts? Thanks!


#2

I have the same problem and found this solution just now, thanks for posting this to tickle me:

try the “Passwords and Keys” app

  • choose Login @ left
  • View > Show Any
  • look for "Encryption passphrase for <Maker, model etc>
  • select Edit menu, delete