Display not able to use 4k resolution

Anyone know where I can find proper NAVI10(AMD firmware) driver that is Open source.

These are the steps I tried(For others with the issue):

My screen has both displayport and HDMI. And has max 4K resolution.

I want my screen output to be at least HD(1920x1080). However my screen seems to choose 1024x768.

When I run xrandr i get:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024    x 768
   default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      76.00*

On boot after selecting PureOS and before I put in password for my encrypted partition. I get the message.

[drm:amdgpu_pci_probe [amdgpu]] ERROR amdgpu requires firmware installed
amdgpu: See https://wiki.debian.org/Firmware for information about missing firmware

So I ran

sudo apt update
sudo apt upgrade
sudo fwupdmgr upgrade
sudo isenkram-autoinstall-firmware

isenkram has output(cut for feaseabiltiy):

info: looking for firmware file rtl_nic/rtl8168h-2.fw requested by kernel
info: some kernel driver requested extra firmware files: Big list of amd stuff
etc. …
info: unable to find any local firmware info for dist byzantium, using info for sid
info: locating packages with the requested firmware files
info: determining whether enabling other components is required
info: No new firmware package with requested firmware detected.

not solved the issue.

I generated an xorg.conf with:

Xorg :0 -configure

And pasted that in /etc/X11/xorg.conf
That leaded to unability to start the the xorg server.
manually starting showed:

AMDGPU(1): [KMS] drm report modesettings isn’t supported.

I also tried cloning linux-firmware.git and put the amdgpu folder in /lib/firmware/amdgpu (this folder needed to be created). and ran

sudo update-initramfs -c -k all

Cloning the drive seems to solve the issue.

However I think it is not FSF approved firmware. It is blobware if i am correct.

Anyone know where to get a proper NAVI10 firmware.

I saw it’s source was leaked. However that is not official driver.