Displaylink on Librem 5

At my work they have Displaylink USB port replicators. They do not work with the Librem 5 out of the box because Displaylink is a proprietary technology.

I discovered this the displaylink-debian project.

According to the project PureOS should be supported.

But when I do:
sudo -E ./displaylink-debian.sh --debug
I get:
Can't open display

See also this issue.

See also: Request - add support for PureOS.

The display-link Post Install Guide writes:
“When you are logging into your session you are using X server (X11) and not Wayland.”

So maybe the issue is Wayland related. But Displaylink should have Wayland support.

Did one of you get Displaylink working on their Librem 5? Or do you have any suggestions or tips to get it working?

1 Like

Were you able to remedy your Display Link issue. I saw your posting last night and gave it a short for my old Librem15v4…and it worked. I have a 27inch on the left, my laptop in the center and have a Samsung 49inch curved monitor that is able to split into two screens. Soooo…essentially, I have 4 screens. Works well so far.

It did not work for me.

I also tried it using the release:

  1. I had to install pciutils manually.
  2. comment the providers=(… line in the displaylink-debian.sh script.
    Was then able to finish the installation and restart, however when running systemctl restart displaylink-driver.service it fails complaining about the evdi module is not found in /lib/modules/… (which is output from modprobe evdi), but the module evdi.ko does exist there. Not sure how to fix it, but it seems like it might be possible to get it working.

See the issue on github here: https://github.com/AdnanHodzic/displaylink-debian/issues/824

I created this issue, a while ago.