DNS Issues - After Crash - Partially Solved

Partially Solved -

I disabled DNSSEC on the PiHole and this resolved the DNS issues on my laptop. So though I am up and working, I will now see how I can get DNSSEC working for the laptop.


In short, how do I flush the DNS cache or reset DNS?


Out of the box Librem 14, PureOS 10.0 - The system crashed when I plugged in a USB-C dock. Upon reboot I did not have network connection (it was working before) due to DNS not resolving IP addresses.

After some troubleshooting I ran sudo chattr +i /etc/resolv.conf and was able to get DNS working again. Except websites I tried while the network was down are not now resolving. For example, when I run dig duckduckgo.com I get a blank A record. Dig @ duckduckgo.com returns

If I manually change the WiFi DNS server to my DNS server sees the request from the laptop to, but locally dig returns a blank A record for DuckDuckGo.

resolv.conf is pointing to my DNS servers (one local pihole, two external). No other systems on my network are having this issue.

Somewhere in the system the DNS is stuck.

I have tried rebooting, sudo killall -HUP dnsmasq, forgetting the WiFi network and reconnecting.

Is this something to do with dnsmasq, avahi-daemon, etc?

Any ideas welcome,



Is it using dnsmasq or is it using systemd-resolved ?

I thought dnsmasq does not have a persistent cache (i.e. only in memory) and so restarting the service will do the job.

Perhaps: resolvectl flush-caches

Are you certain that the problem is on the DNS client? and not on the local DNS server (the PiHole if I understand your setup correctly)?

You may be able to fault isolate by doing a live boot on the DNS client computer. Same computer but essentially a clean configuration.