Docking Station

When the Librem 5 is driving an additional display it requires extra power. That plus the fact that it can’t suspend in that state means that the level of power savings you can get (compared to when it can suspend) will be limited, so the ability to provide power to the Librem 5 when docked is pretty important.

By definition this means attaching the L5 to some sort of other, larger screen. The minimal level of investment here would be a USB-C hub that provides HDMI output. This is assuming you already have a monitor, keyboard and mouse to connect to. If not then you would need to invest in those things, at which point the $200-300 cost for a laptop dock would be comparable.

While everyone has different needs, I’m not sure how common a use case it would be for someone to run graphical programs on the L5 to display on their (presumably faster) Linux laptop. It seems like in that case you’d just run the same Linux application on your laptop instead.

The main benefit of convergence in my mind is being able to run standard Linux desktop applications on the L5 that aren’t yet adaptive to the small screen. In my case it plus a lapdock have completely replaced my need for a personal laptop.

1 Like

The one case that I have encountered a few times over the years - but not frequently enough to influence your thinking any time soon (in my opinion) is:

  • There is a system administration function to be done (hence almost by definition you can’t just run the same application somewhere else), and
  • I don’t know how to do that function from the command line (or it is just really really crappy trying to do it at the command line), and
  • doing the function locally via a GUI is for some reason not an option.

To be clear, I am not talking about the Librem 5 here as far as my past experience goes.

However to illustrate the point for the Librem 5: If you want to add a new user, the GUI app for that is not adaptive and does not work adequately on the Librem 5 screen - and clearly it is not viable to add the user on another computer (unless you are using distributed authentication but let’s put that to one side). So the only option is adding users from the shell, which is fine for me but may be a showstopper for some customers.

But the answer in that specific case is to fix the GUI app that adds new users (and/or add the default user as part of the initial installation process, as for example Ubuntu does).

I got the CSV-1599 today after finding this thread and have mix results on things.

  1. PD 3.0 pass thru works and charges the L5 nicely IF the source ‘brick’ output is enough. In my first test with the Librem charger, the hub/dock itself consumes 15 of the 18W and the phone doesn’t charge. Switching to a HIGHSAY 100W GaN Charger I get the phone to charge while it’s connected.
  2. The HDMI display worked immediately after switching to the higher wattage power source.
  3. Ethernet jack lights up fine but… the L5 doesn’t recognize the device or automatically recognize the connection. Doing the lazy version of restarting networking (read rebooting) it still did not pick up the wired connection.
  4. NO MOUSE or KEYBOARD recognized by the L5 via USB-A or USB-C ports!! I thought for sure this would be the easy part but, that’s what I get for thinking.
  5. USB flash drive in one of the USB-A ports ALSO goes unrecognized by the L5

Checking lsusb output the L5 lists a hub but, does not change when these other devices are added or removed from the Club-3d CSV-1599 hub/dock.

@quarnero have you successfully used a wired mouse, keyboard, or network connection with this dock? Is there some hidden package I need to install or firmware update for the L5? It feels like I’m so close to having a phone and light duty workstation!!!

:sob: :confounded: :sob: :disappointed: :pleading_face:

1 Like

Ethernet is still not working with Club-3d CSV-1599. Interestingly, as shown above, Obda:8153 Ethernet adapter already works with PureOS out-of-the-box. Anyway, I admit that I wrongly presumed that even 0bda:8156 works with the Librem 5. Therefore I’ll take a look into some workaround for this driver (instead of getting: cdc_ncm with physical Ethernet connection through CSV-1599).

Also, all three data USB ports work for me (I have none mouse nor keyboard issues there), even without providing PD to this hub/dock auto-mounts my USB flash drive on Librem 5 (please test there few other USB flash drives as well).


@cyber_fu, please download related file from: and extract it. Copy 50-usb-realtek-net.rules into /etc/udev/rules.d/, as admin and reboot.

Below photos should at least show that CSV-1599 doesn’t consume much (by itself):

My dock (different from yours) sometimes does not recognize attached USB-A peripherals with the dock’s integrated USB-C connector inserted one way into the L5 but will recognize them with the dock’s USB-C connector flipped 180 degrees when plugged into the L5. Anyway, this is something easy that you might try.

What test did you use to get these results?

I’d like to share here (as testing purpose, nothing else) that even over just one USB-A port from CSV-1599 it is possible to share data/files from compliant USB Flash Drive with the Librem 5 and at the same time (from the very same USB-A port) charge one of my favorite power banks:

It’s written on the packaging. No technical testing beyond changing out the power source and seeing this work with more watts.

Is that file something you did differently than what just comes through normal updates?

Yes, procedure described in my post is needed to make Ethernet working with this dock/hub. It is needed procedure that still isn’t included into PureOS, as when I was streaming something last time (before this workaround) I just thought that I’m using Ethernet connection, yet it was actually 4G Internet connection (you made me aware that I need to find some workaround for making Ethernet working there with PureOS).

I guess that was a good 4G connection! :smile:

1 Like

I’ve noticed on my nextdock that when the Librem 5 sleeps it stops charging which isn’t ideal. I know my Samsung S22 continues to charge from the the dock when the screen blanks so not sure why it does with the Librem. Anyone else notice this behaviour with any other dock setup or is it just the nextdock?

I copied the file per your instructions but still see no change in lsusb or ifconfig -a output. Also tried multiple mice on the USB-A ports with no success. Thanks for they help and something to try but, it seems our goal lies elsewhere.

1 Like

Your 100W GaN power supply have USB-C2 65W and one USB-A power outputs there as well. Please test those there as you are not providing any power to this dock, I guess (over USB-C1 output). For other testing purpose you can use some power bank as well, another PD power supply, some 5V/3A only power supply, yet USB-C1 output on Highsay charging device doesn’t look like usable with the CSV-1599 (not even providing power to the USB 10Gbps data ports on CSV-1599).

EDIT: @cyber_fu, I just did few tests and to me it looks like you are using some advanced USB3.1 or USB3.2 USB-C to USB-C cable to provide power to the CSV-1599 (this will show steady RED light on your Librem 5, but actually not charging it for real, with around 0.1A). Please use charging purpose related USB2.0 (3A or 5A) USB-C to USB-C cable connecting PD power supply and PD input of your CSV-1599.

I order to test if Ethernet works now (without any power supply connected there, and after sudo used to copy 50-usb-realtek-net.rules into /etc/udev/rules.d/) please put your Librem 5 modem HKS down and connect it to the here related dock and afterwards connect Ethernet cable there. As first, simply execute: sudo apt update, you should be able now to use CSV-1599 for any Internet surfing (over Ethernet).

From the charger to the dock I am using the USB-C cable that came with the L5. It only shows red on the device when it’s charging then stops once the battery is 100%. I will test what you suggested later today.

1 Like

Yes, please ensure that you are using USB2.0 cable for connecting it directly to CSV-1599 PD port (this should help there) and not the original Librem 5 USB-C cable:

1 Like

Ok. I tried the other USB-C charging port, the USB-A port, and a different 65w power adapter for a Dell laptop. All gave the same result with a couple small exceptions. While using the Dell adapter I ran lsusb and for a brief moment the 2.0GB flash drive plugged into the dock appeared to be recognized by the L5. It’s worth noting that drive has a light that would always flash briefly when inserted to the dock. Out of curiosity I watched the underside of the old optical USB mouse to see if it also briefly lit up when inserted. It did. I’m guessing from this that the dock has enough power but my issue still lies with the L5 and it’s ability to recognize things through the dock OR the dock itself is having some problem I can’t diagnose. I don’t have one of those fancy little power things like @Quarnero to test the cables and all.

There is no other USB-C charging port, the second USB-C is 10Gbps data output port (please do not repeat such mistakes and use only PD input port for providing power to this dock/hub.

P.S. I’ll read rest of your post afterwards.