Does NFC card readers work on pureos?

I considering buying a NFC card reader for identity management platforms with ID card.
I see some NFC card readers Support linux but i have no idea how this works and what kind software must used.
any advice?

You should probably tell us which device exactly you mean. As you said yourself, some readers do work but some don’t. Depends on the model and how it’s supported.

i don’t know yet, there are so much. :man_shrugging:
The Zoweetek looks ok and says support linux.

someone? bump…

Yes, they say that they support Linux. One way to know for sure if they work with Free Software drivers, would be to have the usb id number of the reader, with that it is easy to check if it is supporter with a free software driver like libccid and others

but to put in another perspective: all the smartcard readers on these two lists should work out of the box with PureOS:


As they use libccid which is Free Software

1 Like

I see Purism’s Librem key is in the “should” list :slight_smile:

Yes, because the developer did not had access to a Librem Key. This page: refers only to the devices the main developer tested himself.

Support for the Librem Key in liccid was tested by purism, which was not difficult since libccid already supported the Nitrokey Pro.
We used for test purposes only, a slightly modified version to make sure it worked, and sent to the libccid developer the results we got from the libccid test tool. And support was added upstream.

Thanks for your information.

I have buy this ACS ACRU39U-N1 Pocketmate II USB eID Card Reader.
it says that it can run on linux but
But when i plug it in, nothing happens.

So what program needs this thing to get it work?

And you tried using it with the eID application of your government? Do they have a linux version of their eID application?

its this website i want to login to:

click “using my identity card”
then “on a computer with nfc card reader”
Then click on that laptop picture in the middle.
then linux Software Center pops up and saying: “no apps available”