Does PureOS work on non-Librem machines?

Hi, I’m trying to install PureOS on a Entroware Triton laptop. I burn the iso to the USB as instructed, however my laptop does not pick it up as a boot device, it just doesn’t appear in the list of detected devices on boot, however the USB drive is visible once the machine is booted into another OS.

My suspicion is that it might have something to do with the UEFI boot, but I’m not really knowledgable enough to be able to investigate that further.

You will probabaly have to enter the BIOS (generally pressing F2 or Delete or something immediately as the boot sequence begins) abd change the boot order to prioritize USB. This will vary a bit from BIOS to BIOS, but I think it’s generally listed rather clearly.

Yes, my bios uses F2 to enter the bios boot menu, but the USB with the ISO burnt to it does show in that menu.

Have you tried other live USBs (say Ubuntu) to see if the issue is specific to the PureOS image you burned or applies to all distros?

Yes. The only other distro I have this issue with is Trisquel. Could it be that my laptop requires a binary blob to function?

Possibly, though I’m not much of an expert in such things. Have you tried changing from UEFI to legacy mode? That might allow PureOS and Trisquel to boot.

I’ve looked all through the boot settings, but I can’t seem to find any option to turn off UEFI boot.