Does the PINE64 hub work with the Librem 5 and an external monitor?

I wanted to test the L5 with an external monitor, so I plugged in the USB-C hub that PINE64 sells with the PinePhone. I tested the USB-A ports on the hub with an external keyboard and mouse, and they worked. I was also able to charge the L5 by plugging into the hub’s USB-C port. When I plugged in a USB Flash memory stick into the hub, the L5 automounted it and automatically displayed its files in Nautilus, so USB OTG appears to be working through the hub as well.

However, I was not able to get the HDMI port on the hub to work. When I plugged into an external monitor, I saw the following errors in dmesg:

54.794272] [drm] hpd irq
[ 1054.999109] [drm] Connector status: 1
[ 1055.000278] [drm] Connector status: 1
[ 1055.029099] cdns-mhdp-imx 32c00000.hdmi: [drm:cdns_mhdp_get_edid_block [cdns_mhdp_drmcore]] *ERROR* get block[0] edid failed: -22
[ 1055.041117] [drm:cdns_dp_connector_get_modes [cdns_mhdp_drmcore]] *ERROR* Invalid edid
[ 1055.050081] [drm] Connector status: 1
[ 1055.052204] imx-dcss 32e00000.display-controller: [drm] fb1: imx-dcssdrmfb frame buffer device
[ 1055.052228] [drm] HDMI/DP Cable Plug In
[ 1055.080282] cdns-mhdp-imx 32c00000.hdmi: [drm:cdns_mhdp_get_edid_block [cdns_mhdp_drmcore]] *ERROR* get block[0] edid failed: -22
[ 1055.092129] [drm:cdns_dp_connector_get_modes [cdns_mhdp_drmcore]] *ERROR* Invalid edid
[ 1055.118184] [drm] Mode: 1024x768p65000
[ 1055.328955] [drm:cdns_dp_bridge_mode_set [cdns_mhdp_drmcore]] *ERROR* Failed to get caps -5
[ 1055.339341] cdns-mhdp-imx 32c00000.hdmi: [drm:cdns_mhdp_train_link [cdns_mhdp_drmcore]] Starting link training
[ 1055.839107] cdns-mhdp-imx 32c00000.hdmi: [drm:cdns_mhdp_train_link [cdns_mhdp_drmcore]] *ERROR* training failed: -110
[ 1055.849823] cdns-mhdp-imx 32c00000.hdmi: [drm:cdns_mhdp_train_link [cdns_mhdp_drmcore]] *ERROR* Failed to start training -110
[ 1055.861218] cdns-mhdp-imx 32c00000.hdmi: [drm:cdn_dp_bridge_enable [cdns_mhdp_drmcore]] *ERROR* Failed link train -110
[ 1088.971992] edt_ft5x06 2-0038: Unable to fetch data, error: -6
[ 1105.927662] [drm] Mode: 1024x768p65000
[ 1106.140094] [drm:cdns_dp_bridge_mode_set [cdns_mhdp_drmcore]] *ERROR* Failed to get caps -5
[ 1106.149134] cdns-mhdp-imx 32c00000.hdmi: [drm:cdns_mhdp_train_link [cdns_mhdp_drmcore]] Starting link training
[ 1106.655102] cdns-mhdp-imx 32c00000.hdmi: [drm:cdns_mhdp_train_link [cdns_mhdp_drmcore]] *ERROR* training failed: -110
[ 1106.666489] cdns-mhdp-imx 32c00000.hdmi: [drm:cdns_mhdp_train_link [cdns_mhdp_drmcore]] *ERROR* Failed to start training -110
[ 1106.678149] cdns-mhdp-imx 32c00000.hdmi: [drm:cdn_dp_bridge_enable [cdns_mhdp_drmcore]] *ERROR* Failed link train -110

The unrecognized EDID tells me that this may be a problem with the monitor rather than the hub, but I was wondering if anyone else has managed to get the PINE64 hub to work with the L5 and an external monitor. Has anyone else tried this?


This what you’re talking about?

1 Like

Does the PINE64 hub work with the Librem 5 and an external monitor?

Yes, my pics/videos are made with this hub:


yes that’s the one.

Strange. I can’t get it to work. I have tried a TV and two monitors with both the PinePhone Beta and the Librem 5 USA. I even tried using two different HDMI cables. Maybe my hub is defective. Are you doing anything special after you plug it in to get it to work?

USB-C cable orientation?

It should automatically work after plugging in. If you can’t get that hub to work with either phone, it’s likely broken.

I noticed that it won’t work if you try to use the (black) Librem 5 cable for the power. Only the Pinephone (red) cable works (as you can see in the pictures).

I actually picked up the pine hub aswell seeing @librem5owner have success with it. I have a 100W laptop brick attached to the hub. It doesn’t work completely all the time. It’s like a shell game. I think I have to plug it in with just the monitor then add power to the hub. I find it really inconsistent. The convergence videos always frustrate me because it doesn’t work cleanly for me at all. Even when I get it working I sometimes have windows too big on the phone screen I can’t drag over or resize. At least last time I tested it no longer overheats when idling and connected. I also found that it was not able to use my logitech master mx, and works much better with a wired mouse.

I’ve had that with an unrelated hub (HooToo Shuttle), and that was after I accepted it’s not going to work. Thanks for sharing, now I know it’s an actual issue.

1 Like

As a data point - I don’t have to do that at all with Baseus docking station. I simply slide the phone into it and everything works - screen, power and USB devices. Only issue I have with it is that USB 3.0 devices are sometimes wonky, but if 3.0 speeds aren’t needed they work perfectly fine in the 2.0 port.

Just a note here…the red cable from Pine64 seems to be necessary.

But as I don’t have my L5 yet, but do have a PP beta convergent package with the Pine64 Dock and red cable.

I also have a NexDock 360.

A month or so ago I tested the PP/Pine64 dock/NexDock360 combo and although there was a good display from the PP on the NexDock, the display on the PP was a mess, being half on the PP display/half blank. I checked the Pine64 forum and there was already a discussion regarding this issue. It seems to me to have been a software issue. I fiddled around with this issue but did not have time and put the PP away.

However recently I upgraded the OS on the PP to Manjaro Plasma 25th Anniversary Edition by KDE and was pleased with the update which has resolved some issues.

So tonight I was lurking on this L5 forum and read through this discussion re using the L5 with the P64 dock. And when the mention of the possibility of the necesitity of using the red P64 cable I thought that I found that to be true when testing this setup a month ago.

So I just completed testing this and found it likely to be the case that the red cable must be necessary to be plugged into the power port on the P64 dock. I tested both with the red cable and with another power cable and the only time the PP display ended up displaying on the NexDock monitor was with using the red cable. I did the test 2 times for each of the red and black cables with the same results.

Note that I say “likely” and “must be necessary”…this is because there may still be issues in the Manjaro Plasma 25th Edition OS or I may need to change some setting(s) in a config file. Although the PP display appeared on the NexDock’s monitor only with using the red cable, I could not get any response from the PP using neither the KB/mouse plugged into the PP dock nor when not plugging in the KB/mouse into the PP dock there was no response from the PP when trying to use the NexDock’s KB and trackpad. I still have to do some further testing and possibily change settings in config files.

But I am happy with the PP with the updated Manjaro Plasma when using the PP stand alone.

I’ll be even happier when getting my L5 that was ordered mid year 2018 :wink:

Isn’t “the red cable” a USB-A to C one? Could that mean that the dock doesn’t handle PD correctly?

Yes, the physical connectors are USB-A to USB-C, but I’m not sure about the compatability or features (built in, or say wired in to which pin outs).

But I do know one of the features of this cable is that the USB will remain active at all times regardless of whether it’s in standby or sleep mode since the color of the plastic inside the USB-A connector of the red cable is red.

I also think that there is some problem with the power delivery in the Pinephone hub, as I demonstrated here:


Here’s an interesting quote from:

Battery University

“With 5V and 500mA available on version USB 1.0 and 2.0, and 900mA on USB 3.0, the USB can charge a small single-cell Li-ion pack.”

“There is, however, a danger of overloading a USB hub when attaching too many gadgets. Charging a device that draws 500mA connected together with other loads will exceed the port’s current limit, leading to a voltage drop and a possible system failure…”

So it may be that different outcomes when using hubs may be caused by variable devices attached to the hub, using different types of chargers, …

Thinking about what spare parts I might dig up to do a test.

For an unpowered hub, yes, that is a possibility. Much less likely for a powered hub. Also less likely when power delivery is negotiated correctly since the hub can negotiate with the device being charged how much power is available.

I recently got me a USB power meter. So the USB connection is made via said device and it will display on the screen details such as current, voltage and PD protocol version.

1 Like

Its a good point still, as one needs to ensure the part that plugs into the wall can provide enough amperage.