Does Zoom Function Normally on the L14 with PureOS?

Hi All,

This might be an 'ignant question, but does anyone successfully use Zoom on their L14’s with PureOS? I enrolled in a class that is over Zoom and I wanted to use my L14, but wasn’t sure how compatible it was.

Second question: even if I can functionally put Zoom on the L14, would it be a fools errand to give Mircosoft a trojan horse into my computer when the entire point of getting the Librem was to get away from big tech? (I don’t know anything about how the guts of Zoom operates, but I assume the worst). Obviously, the class is already set so they aren’t going to switch to a FLOSS program just for me. Just looking for options here.

I have kept the old HP Desktop as my fallback for these situations if putting Zoom on the L14 is self defeating.

Thank you.
Zoom for Linux

I’ve been bitten by this.

Zoom looks for “known” versions of Linux before it will do any screen sharing. Specifically, Zoom looks at /etc/os-release to see what flavour of Linux is running, and PureOS is not on their hard-coded list (or, at least, it wasn’t when this was causing problems for me last year).

If you do want to do screen sharing, this means you will have to log in via the X11 display server interface rather than the usual Wayland. These options are present at the post-decryption, user-login step, via a drop-down to the bottom right of the password field.*

I also run firejail to compartmentalise Zoom (or anything else that seems dodgy, for that matter).

Once installed, in a terminal window, you just run

$ firejail zoom

and it will start the spyware application in a sandbox to mitigate some risk.

There is some merit to the idea of having a separate laptop that runs the more insecure programs you have to use, like Zoom. But that option is not open to everyone.

Running a firejailed Zoom under X11 is a decent compromise if you have to do screen sharing. If not, just run it firejailed under Wayland, and hold your nose while typing the command…

* Of course, you could edit the /etc/os-release file to have something like, say, Debian 11, in it (which is not overly far from the truth), but there is no need to since you can just login via X11. It also runs more slowly on Wayland than on X11, so, horses for courses (as we say in Oz).

1 Like

You are absolutely right. For this reason, I’m using Zoom in a virtual machine on Qubes OS, which by the way works fine on Librem 14. Also, it’s not Microsoft but China.


i have successfully used zoom from flathub. in theory this provides some protection, as it runs without access to the full file system and the process id namespace, etc. however, i use x11 and zoom has a lot of access to the x11 protocol, so probably there is a hole in there somewhere. furthermore, i don’t get the impression that flathub has a crack security team. not saying they are bad at it, but i don’t get the impression of lots of vigilance and organizational strength, e.g., i have more confidence in debian’s security team.


1 Like

Thank you everyone for these responses. They have been very educational to read even though most are more technical than I can really understand.

In light of this, I have concluded that the old HP Desktop is probably going to be my best bet for this situation.

This might even be better too. This way my trackable digital footprint still exists in some capacity. Perhaps it will be a useful decoy. It might have aroused suspicions from “them” if my digital presence disappeared completely. They might send someone in to investigate. :wink:


Zoom worked fine on Pure OS including desktop sharing in X11 and Wayland. For privacy focused individuals I recommend to avoid closed source code, including Zoom and Teams because you don’t know what it actually does on top of official features.

1 Like

Desktop sharing worked for you on Wayland? How?

I just installed the latest version (5.11.3 (3882)) and this is what pops up:

Screenshot from 2022-07-28 12-12-15

You could always use the browser version of zoom

1 Like

I, too, use zoom and Google meet in X11 mode only. Wayland doesn’t work for screen sharing for me. I even can’t record the screen using OBS studio in Wayland; thus use X11 for that also. By the way, we can’t use Librem 14 because of its huge noise in the background to other people on the call with us. I use a workaround to use the laptop for screen sharing and the phone for speaking in the same meeting…

1 Like

That is what I use now too…

1 Like

I don’t remember the details but I had to edit some files in text editor to make it work. I have abandoned even that, because I became more privacy focused. Now I use Qubes OS and all closed source apps are in Windows AppVM. Sorry I can’t be more of help.

1 Like

Yes, I suspect it was what I mentioned above, which I did for a while, which was to edit the /etc/os-release file to have Debian in it instead of PureOS.

I found useful thread here about reducing the annoying fan noise: How to reduce annoying fan noise
But I didn’t do the elaborate mods listed there near the top of the thread, but rather used the CPU power manager GNOME extension mentioned there:

I have successfully run Signal and Zoom calls via laptop without the excessive fan noise that people on these calls used to laugh at. Now it is pretty much silent, having been traded for a slight performance hit. It’s always possible to switch to a higher performance mode if needed, but I mostly just run it in Quiet mode.

I also tend to use a 3.5mm microphone/earphone combo from my phone to bring the microphone closer to my mouth. This also helped to reduce the background noise. If nothing else, it means that only I heard the caller speaking :wink: