Duplicate / outdated docs page for reflashing

Hi there,

I’ve pulled my Evergreen back out of the box after a little while and wanted to reflash with the latest firmware to start from scratch as I was never able to get my phone connected to wifi previously.

I found this blog post:

but when inspecting the linked repo, the relevant script has been moved out.

Sidenote: It sounds like a nice approach to have it independent. Would be great to have the deb package available in the Purism apt repository too. I’m assuming this is the plan and it just hasn’t gotten to the top of the priority pile yet.

Anyway, searching through documentation on ReadTheDocs and Gitlab, it seems that the newer version of the reflashing documentation is at:

But there is an old version still visible at:

Got all my fingers and toes crossed that I’m following the right process atm, but just flagging the documentation mismatches. It’s the classic documentation dilemma - outdated almost the moment its published!

I can’t seem to get it into the right boot mode.

Step 5 says:

Insert the USB-c cable: (red light blinks, no green light)

However mine flashes red green red amber, no matter how many times I do it.

I’m not using the original Librem 5 USB-C cable at the moment, so wondering if there’s some difference there.

On the plus side, this threat of reflashing has caused the phones wifi to start behaving so hopefully I can get up to date naturally…

What output are you seeing in your PC’s terminal when you try to reflash the L5?

Try unplugging the USB-C cable and turn it over and reinsert it into the L5 with the other side of the plug facing up. That worked for me.

1 Like

Good suggestion but no dice.

I fished out the original librem cable too. No change.

The LED does the same pattern if I plug in the cord without holding volume up.

If holding volume up the phone also does a short vibration every ~second.
It does this if I hold volume up then plug it in, or if I plug it in and then hold volume up. Same behaviour.

The reflashing script is still sitting waiting to detect a device.

The instructions on https://developer.puri.sm/Librem5/Development_Environment/Phone/Troubleshooting/Reflashing_the_Phone.html worked for me.

Can you list the exact steps that you did on your PC and how did you install uuu?

For context I’m on a Librem 15v2 running PureOS 10.

uuu was installed using apt without error, however I haven’t yet tried re-inserting the battery in the phone because the LED is not displaying the expected behaviour and I’d rather not brick it.

@amosbatto do you remember if the LED on yours flashed any other colours? Or just the red as is suggested in the docs?

Another suggestion is: Forget about trying to flash (forget about uuu) and just plug your phone into your desktop/laptop via USB and confirm that the phone shows up at all. (If you don’t do the magic stuff on the phone but you do connect it via USB then it should at minimum show up on the host as a network connection and will probably also show up on the host as a small disk.)

Once you are confident about the USB port at each end and the USB cable and the USB cable orientation … you would retry but this time doing the magic stuff to put the phone into boot mode.

I’ve successfully put my phone into boot mode but I don’t have a USB-C port on my host - so I am using a USB-C to USB-A adapter and plugging in to USB-A port on the host (or alternatively a USB-C to USB-A cable). Which of the three are you attempting to do?

Regarding cable orientation, the “beauty” of USB-C is that there are 4 possible orientations if you use a USB-C cable (but only 2 orientations if you use a USB-C to USB-A cable).

I believe that lsusb output on the host should reveal the difference between a Librem 5 that is in boot mode and one that is not. If it’s not getting into boot mode then I don’t think you can do much damage either way i.e. can’t brick but also can’t reflash.


Thanks for continued suggestions :slight_smile:

I’m now using the USB-C to USB-C cable from the Librem 5 connected to the single USB-C slot on the original Librem 15. lsusb shows it as:

Bus 001 Device 101: ID 1d6b:0104 Linux Foundation Multifunction Composite Gadget

and you’re right it’s showing as a network connection.

After doing this, I gave the reflash another try and the device went into boot mode! Got the flashing red so dropped the battery in and it flashed a few colours then went green (not the red described in the docs). Still the script was proceeding and it’s come up wiped and with all the new applications so :tada:


Well done :+1:, and therefore is @Kris just about to mark your post as solution.

1 Like