DVD not playing

Tried to play a DVD today and did not want to play. Another DVD does.
I have played the denied one many times on other laptops. I wonder what is missing.
Screenshot from 2022-01-06 19-22-46
I don’t think the DVD is encrypted. It is a common store bought movie.

Which would make it encrypted?

Have you installed libdvdcss? Suggest reading e.g. https://en.wikipedia.org/wiki/Libdvdcss

If you have access to a backup of the computer when it worked previously if this is the case (is it?) then did you have libdvdcss installed?

It may help to mention what player you are using.

I am using the player that comes with PureOS 10.
The wiki article doesn’t help me much. I am not that good in Debian. I need to know what file to download and install.

Have you recently upgraded and was it working before the upgrade?

Go here: http://download.videolan.org/pub/debian/stable/

and download this file: libdvdcss2_1.2.13-0_amd64.deb

Then sudo dpkg -i libdvdcss2_1.2.13-0_amd64.deb

Warning: That installs libdvdcss2 rather than libdvdcss, and I don’t know for your player whether that will be a problem. I’m using the VLC media player and (with libdvdcss2 installed) VLC is able to play commercial DVDs.

1 Like

That fixed it. The PureOS player and VLC are now working.
Thank you.

1 Like