Ethernet connection problems

Hi! I’m having some issues with my ethernet connection on my newly updated Librem 14.

After I typed sudo apt upgrade my system has been very buggy. My ethernet connection (I don’t have a wifi card) hasn’t been working. It says that I’m connected (with the litte icon on top) but I can not access any website or ping them in terminal. My ethernet cable is fine too since it works on a diffrent system. I tried restarting the computer and the router, nothing changed, I didn’t fiddle with the firewall either… I don’t know any other troubleshoot I could do.

Does anybody have any suggestions?

I think I fixed it… I often just press ctrl + alt + del to shut down my computer but this time I just closed the lid, waited an hour or so and opened it back up (this time I didn’t have to decrypt my hardrive, I just log-in). And this time, I could access the internet via the default “web” app. The time it took to decrypt my hardrive and login to my account were as they were before, meaning that that it didn’t take several minutes to log-in. If you had the same issue as I did, you should try to just close your computer lid, wait a bit and open it up again, this worked for me, could also work for you. I also uninstalled my VPn, so perhaps that might be your issue if you have a VPN. I think that it’s back to normal now.