Exec format error when trying to run flatpak apps, Librem 5


By following the documentation posted about developing applications for Librem 5 phone, I have tried to compile an application with qemu emulation, deployed the resulting flatpak to the phone and installed it. It install fine but when trying to run the app using flatpak run command, I get the following error bwrap: execvp idconfig: Exec format error. I am pretty sure I followed every step shown in the documentation clearly and I am just not sure why this is happening. I have compiled and generated the flatpak file using gnome-builder.

The emulator is using the AMD64 CPU, whereas the phone uses an ARM64 CPU. The phone processor doesn’t understand the executable format in the flatpak, and this is how it warns you.

You must find a way to build the Flatpak for the ARM64 CPU. It’s probably easiest to build the Flatpak on the phone.

EDIT: it’s tracked as an issue now.


Thanks a lot for the response. I’ll update the topic once the issue is solved.

I can’t guarantee that the issue will be resolved quickly, so I would recommend trying some other options. It’s great that you posted here, maybe someone from the forum knows the answer already.